Ask Your Question
0

ROS cannot communicate over network under Natty

asked 2011-06-23 03:23:03 -0500

Mark gravatar image

After updating to Natty, ROS can't communicate locally via network ports no more.

Unable to contact my own server at [http://hostname:48064/].

Changing/setting the variables ROS_MASTER_URI, ROS_HOSTNAME and ROS_IP according to this question didn't help. The tests according to the ROS network troubleshooting guide were partially successful.

  1. ping works for 127.0.0.1, for localhost and for the hostname.
  2. netcat works for 127.0.0.1 and for localhost, but not for the hostname.

Sorry, in case this is a rather pathetic network problem. Maybe it's something specific to Natty?

edit retag flag offensive close merge delete

Comments

Does the error message literally show 'http://hostname:48064/' or your hostname?
dornhege gravatar image dornhege  ( 2011-06-23 04:03:14 -0500 )edit
No, I substituted my actual hostname with `hostname`
Mark gravatar image Mark  ( 2011-06-23 06:48:50 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-06-23 04:52:09 -0500

Mark gravatar image

Alright... it was a rather pathetic network problem. Actually I don't know why, but after the update to Natty, my /etc/hosts file didn't contain the IP adress from my local network anymore. The following entry fixed this.

192.168.1.XXX    hostname
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-23 03:23:03 -0500

Seen: 295 times

Last updated: Jun 23 '11