Ask Your Question
0

Gazebo headless crashes when starting pr2.launch [closed]

asked 2011-09-11 20:21:34 -0500

ChickenSoup gravatar image

updated 2016-05-17 02:48:04 -0500

Hi all,

I am just trying to work out "pr2_mechanism/Tutorials/Running a realtime joint controller". But Gazebo crashes when tried launching pr2. So I ran gazebo headless and it still crashes. Here is the backtrace.

gazebo: /usr/include/eigen3/Eigen/src/Core/DenseStorage.h:69: Eigen::internal::plain_array<T, Size, MatrixOrArrayOptions, 16>::plain_array() [with T = float, int Size = 4, int MatrixOrArrayOptions = 0]: Assertion `(reinterpret_cast<size_t>(array) & 0xf) == 0 && "this assertion is explained here: " "http://eigen.tuxfamily.org/dox-devel/TopicUnalignedArrayAssert.html" " **** READ THIS WEB PAGE !!! ****"' failed.

Program received signal SIGABRT, Aborted.
0x0012e416 in __kernel_vsyscall ()
(gdb) bt
#0  0x0012e416 in __kernel_vsyscall ()
#1  0x01c6f941 in raise () from /lib/libc.so.6
#2  0x01c72e42 in abort () from /lib/libc.so.6
#3  0x01c688e8 in __assert_fail () from /lib/libc.so.6
#4  0x07d324ab in plain_array (this=0xb0b22898, parent=0xb0b21238)
    at /usr/include/eigen3/Eigen/src/Core/DenseStorage.h:69
#5  DenseStorage (this=0xb0b22898, parent=0xb0b21238)
    at /usr/include/eigen3/Eigen/src/Core/DenseStorage.h:102
#6  PlainObjectBase (this=0xb0b22898, parent=0xb0b21238)
    at /usr/include/eigen3/Eigen/src/Core/PlainObjectBase.h:381
#7  Matrix (this=0xb0b22898, parent=0xb0b21238)
    at /usr/include/eigen3/Eigen/src/Core/Matrix.h:276
#8  Quaternion (this=0xb0b22898, parent=0xb0b21238)
    at /usr/include/eigen3/Eigen/src/Geometry/Quaternion.h:256
#9  Identity (this=0xb0b22898, parent=0xb0b21238)
    at /usr/include/eigen3/Eigen/src/Geometry/Quaternion.h:112
#10 PointCloud (this=0xb0b22898, parent=0xb0b21238)
    at /opt/ros/electric/stacks/perception_pcl/pcl/include/pcl-1.1/pcl/point_cloud.h:81
#11 gazebo::GazeboRosCamera::GazeboRosCamera (this=0xb0b22898, 
    parent=0xb0b21238)
    at /tmp/buildd/ros-electric-simulator-gazebo-1.4.2/debian/ros-electric-simulator-gazebo/opt/ros/electric/stacks/simulator_gazebo/gazebo_plugins/src/gazebo_r---Type <return> to continue, or q <return> to quit---
os_camera.cpp:66
#12 0x07d32714 in gazebo::NewGazeboRosCamera (entity=0xb0b21238)
    at /tmp/buildd/ros-electric-simulator-gazebo-1.4.2/debian/ros-electric-simulator-gazebo/opt/ros/electric/stacks/simulator_gazebo/gazebo_plugins/src/gazebo_ros_camera.cpp:61
#13 0x001a880e in gazebo::ControllerFactory::NewController (classname=..., 
    parent=0xb0b21238)
    at /tmp/buildd/ros-electric-simulator-gazebo-1.4.2/debian/ros-electric-simulator-gazebo/opt/ros/electric/stacks/simulator_gazebo/gazebo/build/gazebo/server/controllers/ControllerFactory.cc:65
#14 0x00178406 in gazebo::Sensor::LoadController (this=0xb0b21238, 
    node=0xb0e2e378)
    at /tmp/buildd/ros-electric-simulator-gazebo-1.4.2/debian/ros-electric-simulator-gazebo/opt/ros/electric/stacks/simulator_gazebo/gazebo/build/gazebo/server/sensors/Sensor.cc:218
#15 0x00179286 in gazebo::Sensor::Load (this=0xb0b21238, node=0xb0e2e260)
    at /tmp/buildd/ros-electric-simulator-gazebo-1.4.2/debian/ros-electric-simulator-gazebo/opt/ros/electric/stacks/simulator_gazebo/gazebo/build/gazebo/server/sensors/Sensor.cc:85
#16 0x00e48672 in gazebo::Body::LoadSensor (this=0x85f05c8, node=0xb0e2e260)
    at /tmp/buildd/ros-electric-simulator-gazebo-1.4.2/debian/ros-electric-simulator-gazebo/opt/ros/electric/stacks/simulator_gazebo/gazebo/build/gazebo/server/physics/Body.cc:623
---Type <return> to continue, or q <return> to quit---
#17 0x00e50bf4 in gazebo::Body::Load (this=0x85f05c8, node=0xb0e2d6a8)
    at /tmp/buildd/ros-electric-simulator-gazebo-1.4.2/debian/ros-electric-simulator-gazebo/opt/ros/electric/stacks/simulator_gazebo/gazebo/build/gazebo/server/physics/Body.cc:247
#18 0x0101b08c in gazebo::ODEBody::Load (this=0x85f05c8, node=0xb0e2d6a8)
    at /tmp/buildd/ros-electric-simulator-gazebo-1.4.2/debian/ros-electric-simulator-gazebo/opt/ros/electric/stacks/simulator_gazebo/gazebo/build/gazebo/server/physics/ode/ODEBody.cc:87 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Martin Günther
close date 2016-05-17 03:25:15.481648

Comments

Are you running on 32bit linux? if so, might be a bug: https://code.ros.org/trac/ros-pkg/ticket/5164
hsu gravatar image hsu  ( 2011-09-12 13:27:28 -0500 )edit
yes 32bit linux. I'm running ros-electric, in Ubuntu 11.04
ChickenSoup gravatar image ChickenSoup  ( 2011-09-12 13:42:45 -0500 )edit
yes, in that case, the bug applies. I've checked in a patch in trunk, will make a release soon. It would be great if you (or anyone with a 32bit machine) can please test out the patch by compiling from source? Thanks.
hsu gravatar image hsu  ( 2011-09-12 14:11:50 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2011-09-20 18:07:03 -0500

seanarm gravatar image

I too had this error with electric on Ubuntu 11.04 32bit. hsu's fix in simulator_gazebo/trunk remedies the problem.

edit flag offensive delete link more

Comments

the patch has been released, please check your /opt/ros/electric/stacks/simulator_gazebo/CMakeLists.txt to see if rosbuild_make_distribution(#) >= 1.4.4. Let me know if the problem still persists.
hsu gravatar image hsu  ( 2011-09-20 18:35:44 -0500 )edit
Just released 11 hours ago? I encountered the problem after a fresh synaptic install of electric on a fresh install of ubuntu 11.04 immediately before I posted.
seanarm gravatar image seanarm  ( 2011-09-21 05:44:11 -0500 )edit
ah, right, the deb's hasn't propagated out yet, right now it's on 1.4.3. You can check the release status at http://www.ros.org/debbuild/electric.html, look for simulator_gazebo for your platform.
hsu gravatar image hsu  ( 2011-09-21 05:51:14 -0500 )edit
Thank you all for the replies. With the 1.4.5, it crashes with "terminate called after throwing an instance of 'Ogre::RenderingAPIException'". So, I assume it is a problem with my graphics. Then, when I ran gazebo headless, it does not crash but the pr2 controllers do not get loaded.
ChickenSoup gravatar image ChickenSoup  ( 2011-09-27 16:13:34 -0500 )edit

Question Tools

Stats

Asked: 2011-09-11 20:21:34 -0500

Seen: 476 times

Last updated: May 17 '16