Ask Your Question
0

collada_urdf error: No name given for the robot

asked 2011-07-24 08:04:28 -0500

Pi Robot gravatar image

Hello,

I am using the latest Diamondback debs and the latest orrosplanning stack from SVN. I am trying to view a Collada file in RViz using the instructions found here. When I run the command:

$ roslaunch orrosplanning collada_rviz_display.launch model:=my_collada_file.dae

I get the following messages and ERROR:

process[collada_joint_publisher-1]: started with pid [12460]
process[rviz-2]: started with pid [12461]
[ INFO] [1311537409.715739024]: Loading general config from [/home/patrick/.rviz/config]
[ INFO] [1311537409.716240542]: Loading display config from [/home/patrick/.rviz/display_config]
[ERROR] [1311537410.519508816]: No name given for the robot.
[ERROR] [1311537410.596324365]: No name given for the robot.

The robot model shows up fine in the OpenRAVE viewer that opens, but not in RViz. I have tried it with several different Collada files found in the collada_robots package all with the same result.

--patrick

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-07-25 03:37:24 -0500

Nick Armstrong-Crews gravatar image

updated 2011-07-25 03:38:21 -0500

The following suggestions worked for me...

from Ryohei Ueda:

Hi Nick

have you (re-)compiled rviz with the trunk robot_model stack?

-- ryohei

from rosen diankov:

Hi Nick,

Ryohei is right. diamondback rviz is compiled with the robot model 1.4 (you can check using ldd). You'll have to recompile rviz with robot model 1.5 for things to work correctly.

good luck! rosen,

edit flag offensive delete link more

Comments

Thanks Nick--yes, compiling rviz against robot_model 1.5 worked for me up to a point. It works as follows: if I start with an OpenRAVE XML definition of my robot that I hand coded according to the OpenRAVE spec, then convert it to Collada using "rosrun openrave openrave -save pi_robot.dae pi_robot.xml", then I can view it in OpenRAVE and RViz using "roslaunch orrosplanning collada_rviz_display.launch model:=pi_robot.dae". But I saw your thread on ros-users and like you, I am also trying to use a Blender (2.58) model that I export to Collada. Rosen suggested that I handle the Collada version issue (1.4 versus 1.5) by simply editing the resulting .dae file and changing the header to '<COLLADA version="1.5.0" xmlns="http://www.collada.org/2008/03/COLLADASchema"> '. However, so far I just get a list of errors from both Diamondback and Electric ...(more)
Pi Robot gravatar imagePi Robot ( 2011-07-25 03:54:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-24 08:04:28 -0500

Seen: 1,045 times

Last updated: Jul 25 '11