Ask Your Question
1

Mercurial for simulator_GAZEBO_1.2

asked 2011-04-09 03:44:03 -0600

ASMIK2011ROS gravatar image

Dear ROS gurus, please, help me with the following. While trying to compile gazebo (downloaded from here https://code.ros.org/svn/ros-pkg/stac... ) with rosmake, I get the following: Failed to find rosdep mercurial for package gazebo_plugins on OS:ubuntu version:10.04

Could someone please explain, how to fix this dependency(?) Hope for your help very much.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
2

answered 2011-04-10 02:26:30 -0600

updated 2011-04-15 21:13:06 -0600

The solution is to use Diamondback.

You are probably using CTurtle, right? I tried to reproduce your behaviour, and this is what I get, using CTurtle:

[ rosmake ] No package specified.  Building stack ['simulator_gazebo']          
[ rosmake ] Packages requested are: ['simulator_gazebo']                        
[ rosmake ] Logging to directory/home/martin/.ros/rosmake/rosmake_output-20110410-152750
[ rosmake ] Expanded args ['simulator_gazebo'] to:
['gazebo_plugins', 'gazebo_worlds', 'gazebo_tools', 'gazebo']
[ rosmake ] Checking rosdeps compliance for packages simulator_gazebo.  This may take a few seconds.
Failed to find stack for package [rosgraph_msgs]
Failed to load rosdep.yaml for package [rosgraph_msgs]:Cannot locate installation of package rosgraph_msgs: [rospack] couldn't find package [rosgraph_msgs]. ROS_ROOT[/opt/ros/cturtle/ros] ROS_PACKAGE_PATH[/home/martin/ros:/opt/ros/cturtle/stacks]
Failed to find rosdep mercurial for package gazebo_plugins on OS:ubuntu version:10.04
(...)
WARNING: Rosdeps [u'mercurial', u'mercurial', u'mercurial', u'mercurial'] could not be resolved

This tells us that there are two errors:

  1. rospack cannot find the package rosgraph_msgs
  2. rosdep cannot find a rosdep.yaml file that specifies the debian package name for the dependency "mercurial"

Both errors can be fixed by switching to Diamondback, since rosgraph_msgs is new in Diamondback, and "mercurial" is now defined in /opt/ros/diamondback/ros/rosdep.yaml. Don't worry, you can install Diamondback and CTurtle side-by-side. Just install Diamondback and run the following:

source /opt/ros/diamondback/setup.bash   # if running bash

or

source /opt/ros/diamondback/setup.zsh    # if running zsh

and then:

roscd simulator_gazebo
rosmake --rosdep-install
edit flag offensive delete link more

Comments

Hi! Thanks a lot for your answer! I installed diamondback, but can't run the code, which you suggested. That's what I get, after running the first line of it: >> youbot@oleksandr-laptop:~$ source /opt/ros/diamondback/setup.zsh No command 'compctl' found, did you mean: Command 'compcal' from package 'ggz-kde-client' (universe) compctl: command not found No command 'compctl' found, did you mean: Command 'compcal' from package 'ggz-kde-client' (universe) compctl: command not found No command 'compctl' found, did you mean: Command 'compcal' from package 'ggz-kde-client' (universe) compctl: command not found No command 'compctl' found, did you mean: Command 'compcal' from package 'ggz-kde-client' (universe) compctl: command not found
ASMIK2011ROS gravatar imageASMIK2011ROS ( 2011-04-15 20:17:48 -0600 )edit
That's what I get, after running the second line of it: >> youbot@oleksandr-laptop:~$ rosmake --rosdep-install [ rosmake ] No package or stack specified. And current directory 'youbot' is not a package name or stack name. [ rosmake ] Packages requested are: [] [ rosmake ] Logging to directory/home/youbot/.ros/rosmake/rosmake_output-20110416-101637 [ rosmake ] Expanded args [] to: [] [ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.
ASMIK2011ROS gravatar imageASMIK2011ROS ( 2011-04-15 20:18:58 -0600 )edit
you might be running bash? in that case, do "source /opt/ros/diamondback/setup.bash" instead.
hsu gravatar imagehsu ( 2011-04-15 20:33:31 -0600 )edit
youbot@oleksandr-laptop:/opt/ros/diamondback$ source /opt/ros/diamondback/setup.bash youbot@oleksandr-laptop:/opt/ros/diamondback$ rosmake --rosdep-install [ rosmake ] No package or stack arguments and the current directory is not the correct path for stack 'diamondback'. Stack directory is: /home/youbot/ros_stacks/ros-pkg/simulator_gazebo/tags/diamondback. [ rosmake ] Packages requested are: [] [ rosmake ] Logging to directory/home/youbot/.ros/rosmake/rosmake_output-20110416-105453 [ rosmake ] Expanded args [] to: [] [ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.
ASMIK2011ROS gravatar imageASMIK2011ROS ( 2011-04-15 20:57:36 -0600 )edit
I've edited my answer. You have to run the command "roscd simulator_gazebo" first.
Martin Günther gravatar imageMartin Günther ( 2011-04-15 21:13:50 -0600 )edit
This helped. Thank you VERY VERY VERY much!!!
ASMIK2011ROS gravatar imageASMIK2011ROS ( 2011-04-16 00:47:52 -0600 )edit
0

answered 2011-04-10 08:23:59 -0600

hsu gravatar image

updated 2011-04-17 21:01:06 -0600

Hi, for cturtle, simulator_gazebo from the 1.2 branch is the designated development branch for cturtle. But it is recommended if you could run the latest version (diamondback) if possible.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-04-09 03:44:03 -0600

Seen: 414 times

Last updated: Apr 17 '11