Ask Your Question
1

OGRE EXCEPTION(3:RenderingAPIException): Zero sized texture surface on texture high_def_sensor_RttTex face 0 mipmap 0

asked 2011-04-05 17:29:21 -0500

bhh1988 gravatar image

updated 2011-04-05 17:32:04 -0500

Eric Perko gravatar image

Hi,

I tried running the command roslaunch pr2_empty_world.launch, and after starting a bunch of processes and gazebo successfully initializing, the gazebo window suddenly closes and I get this error message:

Gazebo successfully initialized terminate called after throwing an instance of 'Ogre::RenderingAPIException' what(): OGRE EXCEPTION(3:RenderingAPIException): Zero sized texture surface on texture high_def_sensor_RttTex face 0 mipmap 0. Probably, the GL driver refused to create the texture. in GLTexture::_createSurfaceList at /tmp/buildd/ros-diamondback-visualization-common-1.4.0/debian/ros-diamondback-visualization-common/opt/ros/diamondback/stacks/visualization_common/ogre/build/ogre_src_v1-7-1/RenderSystems/GL/src/OgreGLTexture.cpp (line 406) Service call failed: transport error completing service call: unable to receive data from sender, check sender's logs for details spawning success None [gazebo-1] process has died [pid 26615, exit code -6].

My graphics card is a GeForce4 MX 420 and I am using the latest driver for it.

Thanks for your help!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2011-04-06 01:54:20 -0500

nkoenig gravatar image

You said that empty_world works. Could you try running other worlds without the PR2? Also try loading the PR2 without the highdef (prosilica) sensor. You can do this by commenting out the appropriate code in the urdf. Go to "pr2_description", and look around for prosilica.

edit flag offensive delete link more

Comments

Things like coffee_cup and simple_box.launch,etc. aren't getting past the "waiting for service spawn_gazebo_model" line. But this problem seems to be different from my original problem. BTW taking out the prosilica lines worked for the pr2_empty_world.launch (though its quite laggy). Why is this?
bhh1988 gravatar image bhh1988  ( 2011-04-06 09:12:35 -0500 )edit
1

answered 2011-04-05 17:38:04 -0500

Eric Perko gravatar image

updated 2011-04-05 20:08:22 -0500

The GeForce4 series is pretty old. It may not be supported by Ogre/Rviz. See this thread on the mailing list: http://code.ros.org/lurker/message/20110217.012153.3788f53a.en.html

It may be that the card just doesn't have enough memory to hold the empty world and a PR2. Have you tried just the empty world by itself (roslaunch gazebo_worlds empty_world.launch)? If that works, try working up more complex worlds available in the gazebo_worlds package and see if, at some level of complexity/number of triangles/textures, Ogre starts crashing.

edit flag offensive delete link more

Comments

hmm empty_world works. Most of the other launch scripts fail for me with a different kind of error. They generally either halt at "waiting for service spawn_gazebo_model" or "spawn_urdp_model", eventually ending with "Service call failed: unable to connect to service: [Errno 111] Connection refused"
bhh1988 gravatar image bhh1988  ( 2011-04-05 20:00:11 -0500 )edit
Is it erroring after Gazebo crashes/closes? Also, you could try launching gazebo with the `-r` flag, which doesn't start up the GUI. See the `empty_world_no_x.launch` file for an example. Perhaps that would allow you to launch a more complex example without crashing, since it disables OGRE.
Eric Perko gravatar image Eric Perko  ( 2011-04-05 20:12:19 -0500 )edit
It gives me that error without ever saying "Gazebo successfully initialized" and I never get the window so it seems to be happening before. Adding the -r flag doesn't do anything. Does that mean this service error now is not a graphics problem?
bhh1988 gravatar image bhh1988  ( 2011-04-05 20:39:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-04-05 17:29:21 -0500

Seen: 4,655 times

Last updated: Apr 06 '11