Ask Your Question
0

Frame offset when using Moveit! on PR2

asked 2013-10-30 13:48:31 -0500

lindzey gravatar image

updated 2014-11-22 17:05:42 -0500

ngrennan gravatar image

Note: cross-posted to moveit-users. Thread here

I'm using ROS groovy on a PR2, and trying to use Moveit! for a pick & place application. I'm using the default move_group.launch file from pr2_moveit_config, along with the default robot start bringup.

When I look at rviz, the robot representations from the RobotModel and the PlanningScene do not line up, as seen below:

image description

Unfortunately, the PlanningScene frame is the one that's wrong when compared to the actual sensor data, as determined by observing where it thought the arm was positioned relative to displayed kinect points vs. where it actually is.

After noticing that this offset changed a little every time I restarted the move_group node, I discovered that Moveit! uses odom_combined and the transform to odom_combined is published by the robot_pose_ekf node, and it wasn't 0 despite the robot being stationary. So, I tried killing that node, and using the static transform publisher to publish a 0 transform.

This seemed to help, but didn't fix the entire offset.

Is there some configuration step that I'm missing? Do I need to tell Moveit! to use a different frame? (If so, how, and which frame?)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-11-06 13:54:13 -0500

lindzey gravatar image

updated 2013-11-06 14:18:35 -0500

This goes away once I change the Fixed Frame in rviz. It doesn't seem to matter what to, so long as it gets changed.

edit flag offensive delete link more
0

answered 2013-11-03 09:29:40 -0500

Athoesen gravatar image

The interaction is kind of finicky. I know that I just uninstalled and reinstalled the necessary MoveIt components and the problem resolved itself. Your robot build should still be there.

edit flag offensive delete link more

Comments

I just tried `sudo apt-get remove ros-groovy-moveit*; sudo apt-get install ros-groovy-moveit*`, but the problem persists.`

lindzey gravatar image lindzey  ( 2013-11-05 05:29:12 -0500 )edit

I got it working using ROSHydro, I'm not sure if it's a Groovy-specific problem

Athoesen gravatar image Athoesen  ( 2013-11-06 05:02:12 -0500 )edit

Nope - I just upgraded my robot to Hydro, and am seeing the exact same thing.

lindzey gravatar image lindzey  ( 2013-11-06 13:45:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-30 13:48:31 -0500

Seen: 235 times

Last updated: Nov 06 '13