Ask Your Question
0

Replaced binary with source, won't compile

asked 2013-10-29 16:22:56 -0600

aespielberg gravatar image

Hi all,

Working on Ubuntu 12.04, ROS Hydro

Recently, I decided I wanted to make changes to robot_state_publisher. In order to do this, I downloaded the source code and made changes, added its location to my ROS_PACKAGE_PATH (I can roscd to it just fine), and apt-get purge'd the binary. Unfortunately, now when I try to rosmake a package that depends on robot_state_publisher, I get the error I've included below. I've tried deleting the ~/.ros folder's contents (and re-initializing) and make clean-ing. Neither fix this problem.

I'm totally stumped. Does anyone have any ideas on this? It shouldn't be looking for that .pc file because it should no longer be looking for the binary, but I don't know what to delete or add to make it look in source.

mkdir -p bin
  cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=/opt/ros/hydro/share/ros/core/rosbuild/rostoolchain.cmake  ..
  [rosbuild] Building package youbot_description
  [rosbuild] Cached build flags older than manifests; calling rospack to get flags
  Failed to invoke /opt/ros/hydro/bin/rospack cflags-only-I;--deps-only youbot_description
  Package robot_state_publisher was not found in the pkg-config search path.
  Perhaps you should add the directory containing `robot_state_publisher.pc'
  to the PKG_CONFIG_PATH environment variable
  No package 'robot_state_publisher' found
  [rospack] Error: python function 'rosdep2.rospack.call_pkg_config' could not call 'pkg-config --cflags-only-I robot_state_publisher' without errors


  CMake Error at /opt/ros/hydro/share/ros/core/rosbuild/public.cmake:129 (message):


    Failed to invoke rospack to get compile flags for package
    'youbot_description'.  Look above for errors from rospack itself.
    Aborting.  Please fix the broken dependency!

  Call Stack (most recent call first):
    /opt/ros/hydro/share/ros/core/rosbuild/public.cmake:227 (rosbuild_invoke_rospack)
    CMakeLists.txt:12 (rosbuild_init)


  -- Configuring incomplete, errors occurred!
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-10-30 03:18:37 -0600

maska gravatar image

Have you tried "catkin_make clean"?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-10-29 16:22:56 -0600

Seen: 182 times

Last updated: Oct 30 '13