ROS2 binary installation not working on Windows

asked 2018-06-19 10:48:29 -0500

aks gravatar image

updated 2018-06-19 12:21:01 -0500

EDIT : This question concerns only fastrttps package.

Tried to install ROS2 from Binary. As soon as I download ROS2, extract it to C:\dev\ROS2 and call the local_setup.bat, run the demo nodes ros2 run demo_nodes_cpp talker , the program crashes with a window saying : A problem occured in the execution of the program. Please close it. The same happens for the python node as well.

Can anyone check it ?

edit retag flag offensive close merge delete

Comments

Please mention which version you downloaded as well as post the exact error message you are getting.

Dirk Thomas gravatar imageDirk Thomas ( 2018-06-19 10:57:23 -0500 )edit

I downloaded ros2-ardent-package-windows-opensplice-AMD64.zip and ros2-ardent-package-windows-fastrtps-opensplice-AMD64.zip. The exact error is : the system cannot find the specified path. Even on double clicking the file @Dirk Thomas

aks gravatar imageaks ( 2018-06-19 11:00:59 -0500 )edit

I don't believe "double clicking" is what you are supposed to do with local_setup.bat.

gvdhoorn gravatar imagegvdhoorn ( 2018-06-19 11:02:05 -0500 )edit

@gvdhoorn : yes i know i am not supposed to do that. But after getting the same error multiple times, I was curious to know what happens if i manually try to run it by double clicking...and resulted in the same error message which was a bit strange.

aks gravatar imageaks ( 2018-06-19 11:04:00 -0500 )edit

Is the problem the same with ros2-ardent-package-windows-fastrtps-AMD64.zip? Do you have OpenSplice installed? Please set the env var COLCON_TRACE=1 to get more information where it fails. You could also comment out the line @Echo off in the local_setup.bat file to show every command.

Dirk Thomas gravatar imageDirk Thomas ( 2018-06-19 11:28:46 -0500 )edit

OpenSplice is installed, the variable OSPL_HOME is set correctly. COLCON_TRACE = 1 set (what is it exactly ?). @Echo off commented. Error : C:\WINDOWS\system32>if exist "C:\dev\ros2\share\ament_clang_format\local_setup.bat" call "C:\dev\ros2\share\ament_clang_format\local_setup.bat"

aks gravatar imageaks ( 2018-06-19 11:37:07 -0500 )edit

After this comes the error : System cannot find the specified path

aks gravatar imageaks ( 2018-06-19 11:37:34 -0500 )edit

@Dirk Thomas : The same problem doesnt repeats if I download only fastrttps package but the moment I try to run a demo node, it crashes stating : A problem occured in the execution of the program. Please close it. Both for py and cpp node.

aks gravatar imageaks ( 2018-06-19 11:44:45 -0500 )edit