Ask Your Question
0

Error using ur5_driver on Groovy

asked 2013-10-25 13:21:09 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi there, I am working on ROS-Groovy installed on precise 12.04 linux machine. when trying to connect to ur5 robot using the instructions given in README.md file found in this link github.com/ros-industrial/universal_robot... I get the below error.

[ERROR] [WallTime: 1382729859.230626] Loaded calibration offsets: {} 
Traceback (most recent call last): 
  File "/home/robotlabpc/catkin_ws/src/universal_robot/ur_driver/src/ur_driver/driver.py", line 697, in <module> 
    if __name__ == '__main__': main() 
  File "/home/robotlabpc/catkin_ws/src/universal_robot/ur_driver/src/ur_driver/driver.py", line 648, in main 
    program = fin.read() % {"driver_hostname": get_my_ip(robot_hostname, PORT)} 
  File "/home/robotlabpc/catkin_ws/src/universal_robot/ur_driver/src/ur_driver/driver.py", line 609, in get_my_ip 
    s = socket.create_connection((robot_ip, port)) 
  File "/usr/lib/python2.7/socket.py", line 571, in create_connection 
    raise err 
socket.error: [Errno 111] Connection refused 
[ur_driver-2] process has died [pid 22866, exit code 1, cmd /home/robotlabpc/catkin_ws/src/universal_robot/ur_driver/src/ur_driver/driver.py 192.168.1.5 __name:=ur_driver __log:=/home/robotlabpc/.ros/log/a1eeed26-3dac-11e3-8aa7-0013d41b020f/ur_driver-2.log]. 
log file: /home/robotlabpc/.ros/log/a1eeed26-3dac-11e3-8aa7-0013d41b020f/ur_driver-2*.log

Can some one please provide steps to configure the server side (ROS) and any details which needs attention on the polyscope touch screen interface.

Any help in this regard will be good. Thanks in advance.

Regards, Murali

edit retag flag offensive close merge delete

Comments

Are you able to ping your robot?

sedwards gravatar imagesedwards ( 2013-10-27 15:55:57 -0500 )edit

Hi Shaun, Yes, I was able to ping the robot, I defined the Robot and My PC to have static IP addresses. Robot is configured listen on port 30000. When I launch ur5.launch, I get warning msgs stating that, I have not configured the calibration offsets for joints. Awaiting your response, Thank you.

MKI gravatar imageMKI ( 2013-10-27 22:23:13 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2013-10-26 00:21:51 -0500

gvdhoorn gravatar image

It would seem the host at the IP address specified (192.168.1.5) is not accepting any connections, hence the socket.error: [Errno 111] Connection refused error.

Are you sure that you specified the correct IP for your UR5? You can find the IP of the robot on the SETUP Robot screen, under Setup NETWORK.

edit flag offensive delete link more

Comments

Firstly.Thank you for the response. I did configure the IP address on both UR5 and my pc as static. $ ping 192.168.1.5 also worked, however this command $ roslaunch ur_bringup ur5.launch robot_ip:=192.168.1.5 gives the above error. I believe,I am missing few configuration on my pc,(wrt driver.py).

MKI gravatar imageMKI ( 2013-10-27 11:35:00 -0500 )edit

AFAIK, it should *just work*. Network setup seems correct, if you can ping the robot. Does the *log* on the teach pendant show anything out of the ordinary? Does a `telnet 192.168.1.5 30002` succeed (alternatively, try `nc 192.168.1.5 30002`)? Your terminal should be flooded with 'unreadable text'.

gvdhoorn gravatar imagegvdhoorn ( 2013-10-28 08:15:48 -0500 )edit

Hi, $ telnet 192.168.1.5 30002 did seem to work, My terminal got flooded with junk binary data. Which means there is a path from my pc to the robot. Is it possible to perform the same from the touch screen interface of the robot to my pc? If yes, could please clarify the same. Thank you.

MKI gravatar imageMKI ( 2013-11-09 00:47:20 -0500 )edit

@MuraliKrishnan: no, the TP cannot telnet to your PC. But you only get data back if the network setup is correct. EDIT: you could however write a small program that uses the socket functions to connect from the TP to your host PC. But I doubt very much that will tell you anything useful.

gvdhoorn gravatar imagegvdhoorn ( 2013-11-10 20:51:59 -0500 )edit

Hi @gvdhoorn: Well after few more tests, I could figure out that except port 30000 I could establish connection via ports 30001, 30002 and 30003, I was also able to test my connection and move the robot using a small python script.Also, $ roswtf gives warning that tf nodes are not connected.

MKI gravatar imageMKI ( 2013-11-14 05:25:04 -0500 )edit
0

answered 2013-11-21 00:25:20 -0500

MKI gravatar image

Hi,

I figured out how to get the driver.py program to run, I changed the PORT = 30001 in the driver.py file and then I started the demo.launch file present in ur5_moveit_config

roslaunch ur5_moveit_config demo.launch

Note: A useful tip at this point is to check the nodes and topics running,

rosrun rqt_graph rqt_graph

here you can view all the nodes which are connected to each other, (useful debugging)

Then finally launch your driver

roslaunch ur_bringup ur5.launch robot_ip:=192.168.1.5

you should on your terminal message like

[INFO] [WallTime: 1385058056.985766] Programming the robot 
[INFO] [WallTime: 1385058056.988982] Programming the robot at 192.168.1.5

... I also obtained an Exception and following it an Error message, Details of which will be posted in a new thread. Thanks for the support, Regards, Murali

edit flag offensive delete link more

Comments

hm, could you provide some information on your robot? Mfg date, software version(s)? Port 30002 should be reachable, AFAIK.

gvdhoorn gravatar imagegvdhoorn ( 2013-11-21 01:11:42 -0500 )edit

@gvdhoorn , You are Right, Except Port 30000,the other Ports, 30001,30002 and 30003 are accessible. The Controller version is "urcontrol 1.6.8733", mfg: aug 03 2012. One question, Are you using any specific program on robot pendant or you are using the ones provided buy the manufacturer?

MKI gravatar imageMKI ( 2013-11-21 09:16:58 -0500 )edit

The idea is that the ur_driver package uploads the driver URScript program to the controller, each time you start the ur_bringup launchfile. The fact that the ur_driver cannot connect to the standard port (30002) means something isn't 'right', which is why I asked.

gvdhoorn gravatar imagegvdhoorn ( 2013-11-22 02:03:51 -0500 )edit

BTW: the demo.launch file from the ur5_moveit_config doesn't use the interface to the real robot: it is just a demo, not even simulation.

gvdhoorn gravatar imagegvdhoorn ( 2013-11-22 02:05:11 -0500 )edit

@gvdhoorn I checked the log on the pendant, It would seem that the pendant is not able to open a socket socket_0 to host: 192.168.1.10 at port 30000 (My Pc). No connection established. I run manufacturers sample program on my pendant and then try to run the Driver.py... Is this the same way you follow?

MKI gravatar imageMKI ( 2013-11-25 07:46:22 -0500 )edit

AFAIK, ur_bringup ur5.launch robot_ip:=X.X.X.X should open up port 50001 on your PC, not 30000. You can try to make a wireshark capture, and determine what is exactly going on - network-wise. In any case, if possible, you might also benefit from updating your UR5 software.

gvdhoorn gravatar imagegvdhoorn ( 2013-11-27 02:16:49 -0500 )edit
0

answered 2013-11-29 02:55:23 -0500

MKI gravatar image

updated 2013-11-29 02:56:04 -0500

All seems to work fine with the August 28 2013 version of the code. However, the recent commits (November 2013 mainly) in the github are causing the code to Break. Thank you @gvdhoorn and @sedwards.

edit flag offensive delete link more

Comments

Hm, that is no good. Could you log an issue with at the github site? Please refer to this page in your issue description and provide all relevant information.

gvdhoorn gravatar imagegvdhoorn ( 2013-11-29 03:04:51 -0500 )edit

sure, I will update it in GitHub,One can notice the changes from a top level by $rosrun rqt_graph rqt_graph for both versions. Thank you again.

MKI gravatar imageMKI ( 2013-11-30 00:19:15 -0500 )edit

If you can, I would still very much like a wireshark capture of the traffic between your PC and the UR5. There haven't been that much changes to the actual driver since 2013-08-28, which is why I'm curious what is going on. If you could link to it from your github issue, I can take a look at it.

gvdhoorn gravatar imagegvdhoorn ( 2013-11-30 00:23:13 -0500 )edit

@MuraliKrishnan: unfortunately I don't have access to a 1.6.X UR5 right now. I've checked to see if the 1.6 URSim shows any issues with the current driver (so including the November commits), but it seems to work fine.

gvdhoorn gravatar imagegvdhoorn ( 2013-12-01 21:24:47 -0500 )edit

Bump!...Is this an issue? Should we log a bug?

sedwards gravatar imagesedwards ( 2013-12-04 14:34:02 -0500 )edit

@sedwards: yes, I think it is and we should. But we need more information.

gvdhoorn gravatar imagegvdhoorn ( 2013-12-04 20:19:27 -0500 )edit

Hi, I just checked the Nov 26 Commit. the latest one with changes made wrt missing_beautifulSoup, It works fine, however I found few exceptions that were thrown, will update the same soon. thanks.

MKI gravatar imageMKI ( 2013-12-05 00:52:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-10-25 13:21:09 -0500

Seen: 1,031 times

Last updated: Nov 21 '13