Ask Your Question
0

openni launching errors.

asked 2011-02-27 14:45:38 -0600

enddl22 gravatar image

updated 2011-03-07 06:14:33 -0600

tfoote gravatar image

Hello, all.

When I tried to launch the openni_camera with the command "roslaunch openni_camera openni_node.launch", I got weird errors.

===================================================================================
[openni_node1-1] process has died [pid 8338, exit code -11].
log files: /home/enddl22/.ros/log/d7cb5b9c-42ef-11e0-9bb4-d8d3857b0f6f/openni_node1-1*.log
===================================================================================

And roswtf said that

===================================================================================
ERROR Could not contact the following nodes:
 * /openni_node1

ERROR Errors connecting to the following services:
 * service [/openni_node1/get_loggers] appears to be malfunctioning: Unable to communicate with service [/openni_node1/get_loggers], address [rosrpc://BEE-PG-46634:60728]
 * service [/openni_node1/set_logger_level] appears to be malfunctioning: Unable to communicate with service [/openni_node1/set_logger_level], address [rosrpc://BEE-PG-46634:60728]

===================================================================================

I have diamondback and cturtle ROS packages and properly switched to diamondback using "source ./setup.bash" command.

Any comments could help me a lot.

Cheers

edit retag flag offensive close merge delete

Comments

Please add the contents of the log file(s) called out: /home/enddl22/.ros/log/d7cb5b9c-42ef-11e0-9bb4-d8d3857b0f6f/openni_node1-1*.log
tfoote gravatar imagetfoote ( 2011-02-28 07:28:01 -0600 )edit

5 Answers

Sort by ยป oldest newest most voted
1

answered 2011-03-07 05:17:06 -0600

Georg gravatar image

Actually it seems, this is depending on your PC hardware. I had the same problem, when trying to run openni_camera on a Pentium 4. On several newer computers Core 2 or Core i5 everything runs fine.

In any case, while the OpenNI stuff is compiled using only SSE2, the NITE libs seem to be compiled for newer CPUs (maybe using SSE3 instructions) and will cause "illegal instruction" errors on older machines.

edit flag offensive delete link more
1

answered 2011-03-11 01:29:03 -0600

Pi Robot gravatar image

I'm not sure if this is the solution to the problems on this thread, but here is how I got openni_camera to compile and work on an older machine that does not have the newer SSE3 requirement that is built into the Diamondback Debian packages and even the CMakeLists.txt file for openni_camera when you download the source. As you can see from the following thread, the trick is to compile openni_camera with only SSE2 support:

http://answers.ros.org/question/341/how-to-compile-openni_ros-with-sse2-only-support

--patrick

edit flag offensive delete link more
0

answered 2011-02-28 07:53:05 -0600

Qi gravatar image

updated 2011-03-07 06:13:34 -0600

tfoote gravatar image

I am having the very similar problem with "roslaunch openni_camera openni_node.launch" under diamondback.

+++++++++++++++++++

...

auto-starting new master
process[master]: started with pid [28004]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to c3682a26-4381-11e0-9de0-000e7faeafc1
process[rosout-1]: started with pid [28017]
started core service [/rosout]
process[openni_node1-2]: started with pid [28025]
process[kinect_base_link-3]: started with pid [28030]
process[kinect_base_link1-4]: started with pid [28031]
process[kinect_base_link2-5]: started with pid [28032]
process[kinect_base_link3-6]: started with pid [28033]
[openni_node1-2] process has died [pid 28025, exit code -4].
log files: /home/pc2/.ros/log/c3682a26-4381-11e0-9de0-000e7faeafc1/openni_node1-2*.log

++++++++++++++++++

Here is what's in the above mentioned log file:

[roscpp_internal] [2011-02-28 13:29:04,244] [thread 0xb696bae0]: [DEBUG] UDPROS server listening on port [33220]
[roscpp_internal] [2011-02-28 13:29:04,261] [thread 0xb696bae0]: [DEBUG] Started node [/openni_node1], pid [28025], bound on [pc2], xmlrpc port [56358]
, tcpros port [40675], logging to [/home/pc2/.ros/log/c3682a26-4381-11e0-9de0-000e7faeafc1/openni_node1-2.log], using [real] time
[roscpp_internal] [2011-02-28 13:29:04,262] [thread 0xb696bae0]: [DEBUG] Shutting down roscpp
edit flag offensive delete link more
0

answered 2011-03-07 09:39:22 -0600

blueskin gravatar image

updated 2011-03-10 02:40:03 -0600

In my case, I had to install unstable version and the following command [this was on cturtle about 2 months ago] its better to use stable versions than unstable.

roslaunch openni_camera openni_kinect.launch

worked perfectly

edit flag offensive delete link more

Comments

What exactly do you mean with unstable version? I just installed unstable, but there is no openni_kinect.launch launchfile. Did you install ni or openni_kinect?
tom gravatar imagetom ( 2011-03-10 02:31:58 -0600 )edit
tom: sry, I should have mentioned that this was on cturtle a while ago (about 2 months), I installed ni stack. no openni_kinect.launch file means did you check the folder manually? it's possible ROS_PACKAGE_PATH settings are not right. whats the output for "rospack find openni_camera" ?
blueskin gravatar imageblueskin ( 2011-03-10 02:39:21 -0600 )edit
ROS_PACKAGE_PATH is set correctly. There is no openni_kinect.launch in newer versions of openni_camera. I installed Diamondback from source 2 weeks ago and everything run perfectly. Then I reinstalled ROS around Monday and am struggling with this. Hope someone can point me in the right direction.
tom gravatar imagetom ( 2011-03-10 03:15:39 -0600 )edit
with diamondback it should be "roslaunch openni_camera openni_node.launch" , I know that's what you tried. I don't know how to fix it then, maybe try rebooting the system
blueskin gravatar imageblueskin ( 2011-03-10 04:04:13 -0600 )edit
0

answered 2011-03-10 05:16:44 -0600

raphael favier gravatar image

Did you consider using the new debian package for kinect? here

Raph

edit flag offensive delete link more

Comments

I've tried that, also installing Diamondback and unstable binaries, building diamondback, ni and openni_kinect from source, reinstalling nite drivers and installing different versions of ROS packages. The last working sources were Diamondback pre-release, but I cannot achieve that now. Cturtle works
tom gravatar imagetom ( 2011-03-10 17:28:04 -0600 )edit
As I wrote above, I tried the same on *various* machines and had the error described in the question above only on an old pentium 4. regardless whether using the diamonback debian packages or a version actually compiled from the sources on that machine. My guess would still be some CPU instruction set problem
Georg gravatar imageGeorg ( 2011-03-11 00:07:23 -0600 )edit
This sounds reasonable, probably some library (may well be NITE) in the newest version does not speak the language of my AMD Sempron 3100+ Pentium 4. I'll try building NITE from source, hopefully it's straightforward to install then... or buying a new computer, at least I'll be able to play SC2 :).
tom gravatar imagetom ( 2011-03-11 01:17:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-02-27 14:45:38 -0600

Seen: 813 times

Last updated: Mar 11 '11