Ask Your Question
0

Depth image on amcl_demo

asked 2014-08-18 14:27:01 -0500

Thiagopj gravatar image

Hi!

I'm having some trouble while trying to access the kinect depth image using amcl_demo.

When i run roslaunch openni_launch openni.launch it works well, and i can access/see topic /camera/depth/image. The problem is when i run roslaunch turtlebot_navigation amcl_demo map_file:=/... It starts all the nodes from the camera (the topic is there as well) but i can't see the depth image from the same topic before. I think i need to enable something but don't know what to do.

Hope you can help. Thank you!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-08-18 18:46:49 -0500

ahubers gravatar image

I would check the launch file at turtlebot_navigation amcl_demo.alunch and see if the parameter depth_registration is true. In general, setting depth_registration to true when running roslaunch openni_launch openni.launch (which is launched via amcl_demo.launch) will kill the regular camera/depth/image, and vice versa.

After launching amcl_demo.launch, try rosrun rqt_reconfigure rqt_reconfigure and select /camera/driver from the drop-down menu. When the depth_registration checkbox is checked, then camera/depth_registered/image_raw should display correctly, but not camera/depth/image. Unchecking it should swap it back.

edit flag offensive delete link more

Comments

Thank you ! Problem solved :)

Thiagopj gravatar image Thiagopj  ( 2014-08-20 19:13:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2014-08-18 14:27:01 -0500

Seen: 138 times

Last updated: Aug 18 '14