Ask Your Question
1

Laser_scan_matcher can't find base_link

asked 2013-10-15 02:22:42 -0600

updated 2013-11-14 10:55:57 -0600

tfoote gravatar image

Greetings. I am using the following launch file to get odometry from laser_scan_matcher so I can use it with amcl:

    <launch>
    <node name="map_server" pkg="map_server" type="map_server" args="/home/skel/test.yaml" output="screen"/>
    <node pkg="hokuyo_transformer" type="laser_to_pcl" name="laser_to_pcl"/>
    <node name="hokuyo" pkg="hokuyo_node" type="hokuyo_node" required="true" output="screen" >
        <param name="frame_id" type="str" value="laser"/> 
        <param name="port" type="string" value="/dev/ttyACM0"/> 
        <param name="intensity" type="bool" value="false"/>
    </node>

  <node pkg="laser_scan_matcher" type="laser_scan_matcher_node" name="laser_scan_matcher_node" output="screen">
    <param name="fixed_frame" value = "odom"/>
    <param name="base_frame" value="base_link"/>
    <param name="use_alpha_beta" value="true"/>
    <param name="use_odom" value="false"/>
    <param name="use_imu" value="false"/>
    <param name="max_iterations" value="10"/>
  </node>
  <node pkg="tf" type="static_transform_publisher" name="base_link_to_laser" args="0.0 0.0 0.0 0.0 0.0 0.0 /base_link /laser 40" />
</launch>

But when I run the file I get the following message :

[ WARN] [1381839319.059787240]: Skipping scan [ WARN] [1381839320.066850260]: Could not get initial transform from base to laser frame, "base_link" passed to lookupTransform argument target_frame does not exist.

However the transform is happenning and is being published since rosrun tf tf_echo /base_link /laser outputs

At time 1381839581.581
- Translation: [0.000, 0.000, 0.000]
- Rotation: in Quaternion [0.000, 0.000, 0.000, 1.000]
            in RPY [0.000, -0.000, 0.000]

Any idea on what is the matter ? I am currently using ROS Hydro on Ubuntu 12.04

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-10-22 02:51:51 -0600

Well, I seem to have solved the problem in the most random way possible but still it may be good to document it. Trying to fiddle around with the code I got the error : symbol lookup error:

/usr/lib/libgsl.so.0: undefined symbol: cblas_dtrsv

Searching, I found that this error is caused by a linker called libutils-gold

I sudo apt-get purge'd it, relinked and recompiled and lo and behold everything is working normally (for the time being at least)

Maybe someone should add it to the laser scan matcher documentation to avoid such unecesary frustration

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-10-15 02:22:42 -0600

Seen: 1,845 times

Last updated: Oct 22 '13