Ask Your Question
0

How to retrieve data from Kinect using rviz

asked 2013-10-06 06:18:49 -0500

ibot gravatar image

updated 2016-10-24 08:35:26 -0500

ngrennan gravatar image

Hello community

I am trying to retrieve image and point cloud data from kinect, which is connected to the ASUS 1025C netbook. The green LED on kinect is blinking, which I am assuming confirms that it is getting power from turtlebot 2 Kobuki base.

All sensors are reported okay on Kobuki dashboard.

At step 3.1.3 (3D Visualization) of turtlebot bringup groovy instructions for installing and setting up turtlebot2 and workstation, when I run

> roslaunch turtlebot_bringup 3dsensor.launch
> roslaunch turtlebot_rviz_launchers view_robot.launch

the display GUI comes up, where turtlebot's position with respect to grid map updates as I manually move turtlebot's base. Laser or Image on the other hand, do not provide any information on this GUI. Selecting Image from the display list brings up the Image window with No Image written in it.

What are other checks that can be performed to make sure the kinect "service" (not sure what ROS term for this would be) is running and to see if the connection is okay?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2013-10-06 09:28:57 -0500

jdorich gravatar image

To see if the Kinect is publishing RGB images, use:

rostopic echo /camera/rgb/image_color

Since rviz isn't displaying the image though, this will most likely fail too. You can also try:

rosnode list

and check for the "openni_camera" node.

edit flag offensive delete link more
0

answered 2013-10-31 04:36:33 -0500

Vince Cross gravatar image

Your problem may be related to this post http://answers.ros.org/question/60562/ubuntu-12042-and-openni_launch-not-detecting-kinect-after-update/

They discuss using Avin2 GitHub snapshot of SensorKinect drivers to solve that problem. It may be worth trying. Instructions for downloading and installing Avin2 can be found here:

http://igorbarbosa.com/articles/how-to-install-kin-in-linux-mint-12-ubuntu/

edit flag offensive delete link more
-1

answered 2013-10-06 10:22:11 -0500

ibot gravatar image

updated 2013-10-06 13:48:18 -0500

Thank you for the pointers.

turtlebot@turtlebot-1025C:~$     rostopic echo /camera/rgb/image_color
WARNING: topic [/camera/rgb/image_color] does not appear to be published yet

rosnode list

did not had openni_camera node listed in it. Following is the output of rosnode list after I ran roslaunch openni_launch once:

turtlebot@turtlebot-1025C:~$ rosnode list
/app_manager
/bumper2pointcloud
/camera/depth/metric
/camera/depth/metric_rect
/camera/depth/points
/camera/depth/rectify_depth
/camera/depth_registered/metric
/camera/depth_registered/metric_rect
/camera/depth_registered/rectify_depth
/camera/disparity_depth
/camera/disparity_depth_registered
/camera/driver
/camera/ir/rectify_ir
/camera/points_xyzrgb_depth_rgb
/camera/register_depth_rgb
/camera/rgb/debayer
/camera/rgb/rectify_color
/camera/rgb/rectify_mono
/camera_nodelet_manager
/cmd_vel_mux
/diagnostic_aggregator
/master_sync_turtlebot_1025C_2026_1107254408
/mobile_base
/mobile_base_nodelet_manager
/robot_pose_ekf
/robot_state_publisher
/rosout
/rviz_1381089680931013393
/turtlebot_laptop_battery
/zeroconf/zeroconf_avahi

Based on ROS documentation, I launched

roslaunch openni_launch openni.launch

It gives the following output. What seems odd to me is where it printed [ INFO] [1381090123.256421081]: No devices connected.... waiting for devices to be connected

turtlebot@turtlebot-1025C:~$ roslaunch openni_launch openni.launch
... logging to /home/turtlebot/.ros/log/92afcf1a-2ec0-11e3-abb1-94dbc9a2c311/roslaunch-turtlebot-1025C-13826.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server (*EDITED* since I don't have previlidges to post URLs)TURTLEBOT:55616/

SUMMARY
========

PARAMETERS
 * /camera/depth/rectify_depth/interpolation
 * /camera/depth_registered/rectify_depth/interpolation
 * /camera/disparity_depth/max_range
 * /camera/disparity_depth/min_range
 * /camera/disparity_depth_registered/max_range
 * /camera/disparity_depth_registered/min_range
 * /camera/driver/depth_camera_info_url
 * /camera/driver/depth_frame_id
 * /camera/driver/depth_registration
 * /camera/driver/device_id
 * /camera/driver/rgb_camera_info_url
 * /camera/driver/rgb_frame_id
 * /rosdistro
 * /rosversion

NODES
  /camera/depth/
    metric (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    points (nodelet/nodelet)
    rectify_depth (nodelet/nodelet)
  /camera/rgb/
    debayer (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
    rectify_mono (nodelet/nodelet)
  /
    camera_base_link (tf/static_transform_publisher)
    camera_base_link1 (tf/static_transform_publisher)
    camera_base_link2 (tf/static_transform_publisher)
    camera_base_link3 (tf/static_transform_publisher)
    camera_nodelet_manager (nodelet/nodelet)
  /camera/
    disparity_depth (nodelet/nodelet)
    disparity_depth_registered (nodelet/nodelet)
    driver (nodelet/nodelet)
    points_xyzrgb_depth_rgb (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
  /camera/ir/
    rectify_ir (nodelet/nodelet)
  /camera/depth_registered/
    metric (nodelet/nodelet)
    metric_rect (nodelet/nodelet)
    rectify_depth (nodelet/nodelet)

ROS_MASTER_URI=*EDITED* since I don't have previlidges to put URLs TURTLEBOT:11311

core service [/rosout] found
process[camera_nodelet_manager-1]: started with pid [13866]
process[camera/driver-2]: started with pid [13878]
[ INFO] [1381090122.820232930]: Initializing nodelet with 4 worker threads.
process[camera/rgb/debayer-3]: started with pid [13926]
[ INFO] [1381090123.256421081]: No devices connected.... waiting for devices to be connected
process[camera/rgb/rectify_mono-4]: started with pid [13942]
process[camera/rgb/rectify_color-5]: started with pid [13967]
process[camera/ir/rectify_ir-6]: started with pid [13983]
process[camera/depth/rectify_depth-7]: started with pid [13998]
process[camera/depth/metric_rect-8]: started with pid [14016]
process[camera/depth/metric-9]: started with pid [14034]
process[camera/depth/points-10]: started with pid [14055]
process[camera/register_depth_rgb-11]: started with pid [14073]
process[camera/depth_registered/rectify_depth-12]: started with pid [14088]
[ INFO] [1381090126.256891688]: No devices connected.... waiting for devices to be connected
process[camera/depth_registered/metric_rect-13]: started with pid [14104]
process[camera/depth_registered/metric-14]: started with pid [14130]
process[camera/points_xyzrgb_depth_rgb-15]: started with pid [14145]
process[camera/disparity_depth-16]: started with pid [14160]
process[camera/disparity_depth_registered-17]: started with pid [14179]
process[camera_base_link-18]: started with pid [14202]
process[camera_base_link1-19 ...
(more)
edit flag offensive delete link more

Comments

I believe in ROS fuerte a breaker (breaker 1 possibly?) had to be enabled to have the turtlebot base power the kinect, but I'm not sure if this is the case in groovy and later. Also, the Kinect doesn't work with USB3.0 so make sure it is plugged into a 2.0 port.

jdorich gravatar image jdorich  ( 2013-10-06 10:25:03 -0500 )edit

When you launch "turtlebot_bringup 3dsensor.launch", does it report any errors

jdorich gravatar image jdorich  ( 2013-10-06 10:29:28 -0500 )edit
1

Please see updates in the answer above. Also, to eliminate doubts about power supply, I just tested powering kinect from its AC power adapter and got same results. Thanks.

ibot gravatar image ibot  ( 2013-10-06 11:57:48 -0500 )edit

Try running the command "lsusb" on the computer that the Kinect is plugged into. There should be three USB devices listed that are associated with the Kinect.

jdorich gravatar image jdorich  ( 2013-10-06 12:35:35 -0500 )edit

Yes, three devices do show up for kinet as NUI audio, motor and camera. I've added the screen print in answer above.

ibot gravatar image ibot  ( 2013-10-06 13:46:16 -0500 )edit

Try: "killall XnSensorServer" then "roslaunch openni_launch openni.launch" and see if you get the same error as before.

jdorich gravatar image jdorich  ( 2013-10-06 14:11:06 -0500 )edit

XnSensorServer: No process found

ibot gravatar image ibot  ( 2013-10-06 14:24:58 -0500 )edit

I'm out of ideas. Those are all the issues that I've ran into with the Kinect. The issue is ROS detecting the Kinect it seems though.

jdorich gravatar image jdorich  ( 2013-10-06 14:28:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-06 06:18:49 -0500

Seen: 5,430 times

Last updated: Oct 31 '13