Ask Your Question
1

TurtleBot Autonomous Navigation Not Moving to Desired Point

asked 2013-08-12 14:18:54 -0600

llSourcell gravatar image

updated 2016-10-24 09:03:09 -0600

ngrennan gravatar image

I'm following the tutorial on Autonomous Navigation of a known map for Turtlebot here

http://www.ros.org/wiki/turtlebot_navigation/Tutorials/Autonomously%20navigate%20in%20a%20known%20map

Rviz Shows up, my map shows up, obstacles show up. Everything looks good basically, but whenever I choose a 2D Nav Goal after choosing a 2D Pose Estimate, the TurtleBot won't move to that point. I don't understand why, but here is the output of

roslaunch turtlebot_navigation amcl_demo.launch map_file:=/tmp/my_map.yaml

core service [/rosout] found
process[camera/camera_nodelet_manager-1]: started with pid [4414]
process[camera/openni_camera_loader-2]: started with pid [4442]
process[camera/depthimage_to_laserscan_loader-3]: started with pid [4469]
process[map_server-4]: started with pid [4488]
process[amcl-5]: started with pid [4503]
process[navigation_velocity_smoother-6]: started with pid [4601]
process[move_base-7]: started with pid [4708]
[ INFO] [1376352712.285728199]: Subscribed to Topics: scan
[ INFO] [1376352712.439712463]: Requesting the map...

[ INFO] [1376352712.449757555]: Still waiting on map...

[ INFO] [1376352713.455649136]: Still waiting on map...

[ WARN] [1376352714.479019249]: You have set map parameters, but also requested to use the static map. Your parameters will be overwritten by those given by the map server
[ INFO] [1376352714.479322989]: Received a 608 X 480 map at 0.050000 m/pix

[ WARN] [1376352719.480832367]: Waiting on transform from /base_footprint to /map to become available before running costmap, tf error: 
[ INFO] [1376352723.641302041]: MAP SIZE: 608, 480
[ INFO] [1376352723.685798187]: Subscribed to Topics: scan
[ INFO] [1376352725.433534739]: Sim period is set to 0.20
[ WARN] [1376352725.540824452]: Trajectory Rollout planner initialized with param meter_scoring not set. Set it to true to make your settins robust against changes of costmap resolution.
edit retag flag offensive close merge delete

Comments

1

Hi, I do not now much about turtlebot navigation, but I'd guess your localization doesn't work. Try using tags without hashes (#), so the right people get to see your question.

Felix Endres gravatar imageFelix Endres ( 2013-08-18 23:20:57 -0600 )edit

Did initialise the robot's pose on the map?

bit-pirate gravatar imagebit-pirate ( 2014-03-11 14:24:14 -0600 )edit

I also have same problem. My turtlebot works correctly with keyboard teleop, but doesn't work with an autonomous navigation I follow ROS web(autonomously navigate in a known map). I doubt that /mobile_base/commands/velocity doesn't respond.

Ken_in_JAPAN gravatar imageKen_in_JAPAN ( 2014-03-12 13:45:27 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
2

answered 2014-07-04 18:47:58 -0600

2ROS0 gravatar image

updated 2014-07-04 19:33:01 -0600

Update: Try shutting down the teleop node if you have it running in parallel. For some reason it blocks the autonomous navigation even when you aren't sending any commands.

I have the same problem. I am running everything in simulation for now. It worked ONCE when I restarted everything but before and after that it doesn't. I'm using Hydro on Ubuntu 12.04.

I'm actually trying to run it on the Clearpath Husky robot and had some problems with that so thought of trying it on the turtlebot in simulation since Husky packages are based on these. Any help would be appreciated, thank you.

edit flag offensive delete link more

Comments

did you solve the issue?

Moda gravatar imageModa ( 2014-08-25 04:34:55 -0600 )edit

Yes. The teleop node was running in parallel. So.

2ROS0 gravatar image2ROS0 ( 2014-10-13 07:58:29 -0600 )edit

This solved a similar problem for me.

cyberguy42 gravatar imagecyberguy42 ( 2016-03-09 12:41:01 -0600 )edit
0

answered 2014-03-10 13:44:05 -0600

jihoonl gravatar image

If you were controlling the robot with a remote workstation, you might want to check the time sync too. Check Network Time protocol here

http://wiki.ros.org/turtlebot/Tutoria...

edit flag offensive delete link more
0

answered 2014-03-06 14:48:50 -0600

lguodongustc gravatar image

Have you turn it off and on again? I had the same problem yesterday, it didn't move and always said like this
[WARN]Clearing costmap to unstuck robot. [WARN]Rotate recovery behaviour started. I restart my turtlebot and it somehow works now. see in this page http://answers.ros.org/question/52279... the explain for the problem may be right.

edit flag offensive delete link more
0

answered 2014-07-07 10:56:16 -0600

McMurdo gravatar image

See the output of rviz's console.

If it says something like, Goal is not in the map frame so it will be ignored, there is your answer.

Change fixed frame to map and then try. It should work. It doesn't work from anything other than the map frame as fixed frame (hence the frame for the move_base_simple/goal).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-12 14:18:54 -0600

Seen: 2,306 times

Last updated: Jul 07 '14