ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

gazebo start issue: segmentation fault

asked 2013-10-03 20:06:42 -0500

yclin gravatar image

updated 2014-01-28 17:18:08 -0500

ngrennan gravatar image

Hello Everyone:

I came across such error when I tried to gazebo from a launch file today:

/opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui: line 2: 6038 Segmentation fault (core dumped) rospack find gazebo/gazebo/bin/gzclient -g rospack find gazebo/lib/

[gazebo_gui-3] process has died [pid 6035, exit code 139, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui __name:=gazebo_gui __log:=/home/yucong/.ros/log/741af39e-2cb9-11e3-b8e5-002564043504/gazebo_gui-3.log]. log file: /home/yucong/.ros/log/741af39e-2cb9-11e3-b8e5-002564043504/gazebo_gui-3*.log

the launch file is: <launch>

<arg name="paused" default="false"/> <arg name="use_sim_time" default="true"/> <arg name="gui" default="true"/> <arg name="throttled" default="false"/>

<group if="$(arg use_sim_time)"> </group>

<node name="gazebo" pkg="gazebo" type="gazebo" args="-u $(find gazebo_worlds)/worlds/" respawn="false" output="screen"/>

<group if="$(arg gui)"> <node name="gazebo_gui" pkg="gazebo" type="gui" respawn="false" output="screen"/> </group>

</launch> but I didn't see anything wrong with the launch file. The error occurs repeatedly but not continuously. Sometimes, it worked ok.

Can someone help me? THank you in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-01-17 12:39:05 -0500

ras_cal gravatar image

I've had this issue. Seems to be related to graphics card. Take a look at and

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2013-10-03 20:06:42 -0500

Seen: 1,715 times

Last updated: Jan 17 '17