Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

gazebo start issue: segmentation fault

Hello Everyone:

I came across such error when I tried to gazebo from a launch file today:

/opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui: line 2: 6038 Segmentation fault (core dumped) rospack find gazebo/gazebo/bin/gzclient -g rospack find gazebo/lib/libgazebo_ros_paths_plugin.so

[gazebo_gui-3] process has died [pid 6035, exit code 139, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui __name:=gazebo_gui __log:=/home/yucong/.ros/log/741af39e-2cb9-11e3-b8e5-002564043504/gazebo_gui-3.log]. log file: /home/yucong/.ros/log/741af39e-2cb9-11e3-b8e5-002564043504/gazebo_gui-3*.log


the launch file is: <launch>

<arg name="paused" default="false"/> <arg name="use_sim_time" default="true"/> <arg name="gui" default="true"/> <arg name="throttled" default="false"/>

<group if="$(arg use_sim_time)"> </group>

<node name="gazebo" pkg="gazebo" type="gazebo" args="-u $(find gazebo_worlds)/worlds/empty.world" respawn="false" output="screen"/>

<group if="$(arg gui)"> <node name="gazebo_gui" pkg="gazebo" type="gui" respawn="false" output="screen"/> </group>

</launch> but I didn't see anything wrong with the launch file. The error occurs repeatedly but not continuously. Sometimes, it worked ok.

Can someone help me? THank you in advance.

gazebo start issue: segmentation fault

Hello Everyone:

I came across such error when I tried to gazebo from a launch file today:

/opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui: line 2: 6038 Segmentation fault (core dumped) rospack find gazebo/gazebo/bin/gzclient -g rospack find gazebo/lib/libgazebo_ros_paths_plugin.so

[gazebo_gui-3] process has died [pid 6035, exit code 139, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui __name:=gazebo_gui __log:=/home/yucong/.ros/log/741af39e-2cb9-11e3-b8e5-002564043504/gazebo_gui-3.log]. log file: /home/yucong/.ros/log/741af39e-2cb9-11e3-b8e5-002564043504/gazebo_gui-3*.log


the launch file is: <launch>

<arg name="paused" default="false"/> <arg name="use_sim_time" default="true"/> <arg name="gui" default="true"/> <arg name="throttled" default="false"/>

<group if="$(arg use_sim_time)"> </group>

<node name="gazebo" pkg="gazebo" type="gazebo" args="-u $(find gazebo_worlds)/worlds/empty.world" respawn="false" output="screen"/>

<group if="$(arg gui)"> <node name="gazebo_gui" pkg="gazebo" type="gui" respawn="false" output="screen"/> </group>

</launch> but I didn't see anything wrong with the launch file. The error occurs repeatedly but not continuously. Sometimes, it worked ok.

Can someone help me? THank you in advance.

gazebo start issue: segmentation fault

Hello Everyone:

I came across such error when I tried to gazebo from a launch file today:

/opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui: line 2: 6038 Segmentation fault (core dumped) rospack find gazebo/gazebo/bin/gzclient -g rospack find gazebo/lib/libgazebo_ros_paths_plugin.so

[gazebo_gui-3] process has died [pid 6035, exit code 139, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gui __name:=gazebo_gui __log:=/home/yucong/.ros/log/741af39e-2cb9-11e3-b8e5-002564043504/gazebo_gui-3.log]. log file: /home/yucong/.ros/log/741af39e-2cb9-11e3-b8e5-002564043504/gazebo_gui-3*.log


the launch file is: <launch>

<arg name="paused" default="false"/> <arg name="use_sim_time" default="true"/> <arg name="gui" default="true"/> <arg name="throttled" default="false"/>

<group if="$(arg use_sim_time)"> </group>

<node name="gazebo" pkg="gazebo" type="gazebo" args="-u $(find gazebo_worlds)/worlds/empty.world" respawn="false" output="screen"/>

<group if="$(arg gui)"> <node name="gazebo_gui" pkg="gazebo" type="gui" respawn="false" output="screen"/> </group>

</launch> but I didn't see anything wrong with the launch file. The error occurs repeatedly but not continuously. Sometimes, it worked ok.

Can someone help me? THank you in advance.