Ask Your Question
0

move_base error: Unable to lookup transform, cache is empty

asked 2013-09-26 06:02:26 -0500

redheli gravatar image

updated 2013-09-26 22:13:31 -0500

Hi,

I am using turtlebot2 (kobuki+kinect) to make the map. gmapping works ok. but when I give the goal in rviz, move_base node omit the error below. It seems base_local_planner can not transform /odom to /map. but I check the tf with command tf_echo, tf_monitor,tf_viewframe. no clue found.

Thanks any help.

I find two similar questions, but no answer.

extrapolation-error-using-hector_mapping-move_base extrapolation-error-of-local-cost-map-in-navigation

my tf tree:

C:\fakepath\Screenshot from 2013-09-26 23:49:56.png

[ WARN] [1380208610.699597142]: Could not transform the global plan to the frame of the controller
[ERROR] [1380208610.899298578]: Extrapolation Error: Unable to lookup transform, cache is empty, when looking up transform from frame [/odom] to frame [/map]

[ERROR] [1380208808.222581361]: Global Frame: /odom Plan Frame size 13: /map

rosrun tf tf_monitor

RESULTS: for all Frames

Frames:
Frame: /base_footprint published by /mobile_base_nodelet_manager Average Delay: -0.0229974 Max Delay: 0.354185
Frame: /camera_depth_frame published by /camera_base_link_2_camera_depth_frame Average Delay: -0.12366 Max Delay: 0.224775
Frame: /camera_depth_optical_frame published by /camera_base_link_2_camera_depth_optical_frame Average Delay: -0.124423 Max Delay: 0.227307
Frame: /camera_link published by /base_footprint_2_camera_link Average Delay: -0.0773685 Max Delay: 0.177639
Frame: /camera_rgb_frame published by /camera_base_link_2_camera_rgb_frame Average Delay: -0.123725 Max Delay: 0.226237
Frame: /camera_rgb_optical_frame published by /camera_base_link_2_crof Average Delay: -0.124212 Max Delay: 0.192336
Frame: /gyro_link published by /base_footprint_to_gyro_link Average Delay: -0.0236702 Max Delay: 0.260833
Frame: /odom published by /slam_gmapping Average Delay: 0.000628292 Max Delay: 0.00346015

All Broadcasters:
Node: /base_footprint_2_camera_link 19.9931 Hz, Average Delay: -0.0773685 Max Delay: 0.177639
Node: /base_footprint_to_gyro_link 98.9593 Hz, Average Delay: -0.0236702 Max Delay: 0.260833
Node: /camera_base_link 10.0197 Hz, Average Delay: -0.125868 Max Delay: 0.112013
Node: /camera_base_link1 10.0197 Hz, Average Delay: -0.121158 Max Delay: 0.226237
Node: /camera_base_link2 10.0171 Hz, Average Delay: -0.126665 Max Delay: 0.0916436
Node: /camera_base_link3 10.0372 Hz, Average Delay: -0.126777 Max Delay: 0.0992249
Node: /camera_base_link_2_camera_depth_frame 10.0304 Hz, Average Delay: -0.120865 Max Delay: 0.224775
Node: /camera_base_link_2_camera_depth_optical_frame 10.0197 Hz, Average Delay: -0.122189 Max Delay: 0.227307
Node: /camera_base_link_2_camera_rgb_frame 10.0196 Hz, Average Delay: -0.126318 Max Delay: 0.092681
Node: /camera_base_link_2_crof 10.0176 Hz, Average Delay: -0.121966 Max Delay: 0.192336
Node: /mobile_base_nodelet_manager 50.2985 Hz, Average Delay: -0.0229974 Max Delay: 0.354185
Node: /slam_gmapping 100.098 Hz, Average Delay: 0.000628292 Max Delay: 0.00346015

rosrun tf tf_echo /map /odom

redheli@redheli-MacBookPro:~/bagfiles$ rosrun tf tf_echo /map /odom
At time 1380209595.389
- Translation: [-0.045, 0.002, 0.000]
- Rotation: in Quaternion [0.000, 0.000, -0.011, 1.000]
in RPY [0.000, 0.000, -0.021]
At time 1380209596.389
- Translation: [-0.045, 0.002, 0.000]
- Rotation: in Quaternion [0.000, 0.000, -0.011, 1.000]
in RPY [0.000, 0.000, -0.021]
At time 1380209597.389
- Translation: [-0.045, 0.002, 0.000]
- Rotation: in Quaternion [0.000, 0.000, -0.011, 1.000]
in RPY [0.000, 0.000, -0.021]
At time 1380209598.389 ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-09-26 06:44:23 -0500

tfoote gravatar image

The usual problem that generates this error is that you are creating the tf::TransformListener without giving it time to fill the buffer. If you create a Listener and then immediately query it before it has recieved messages you will get this sort of error. Are you writing your own node or are you using released nodes? Please provide enough information to reproduce your problem otherwise people can only guess at the problem.

edit flag offensive delete link more

Comments

Hi tfoote, I understand if not use waitForTransform() , tf::TransformListener may count error. I learn from the tf tutorial :) . But all the nodes I use are from groovy original. I only create my package and launch files to load the nodes. I updates the question. Thank you.

redheli gravatar image redheli  ( 2013-09-26 15:10:35 -0500 )edit
1

answered 2013-09-29 04:52:08 -0500

redheli gravatar image

problem solved. it is due to slow wireless connection. change to wire connect and gmapping become much better.

edit flag offensive delete link more

Comments

This solves it only for you! I still have no idea what was the problem exactly.. I have the same problem and I am already on wired connection !??

AbuIbra gravatar image AbuIbra  ( 2013-11-02 19:41:42 -0500 )edit

Hi Abulbra, can parse your code here? if your wired connection can access the internet, try disable it.

redheli gravatar image redheli  ( 2013-11-03 15:18:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-26 06:02:26 -0500

Seen: 1,407 times

Last updated: Sep 26 '13