Ask Your Question
2

failed to create base_local_planner after changing global planner

asked 2013-09-19 02:08:33 -0500

babtu gravatar image

updated 2013-12-12 20:15:50 -0500

tfoote gravatar image

I want to do the comparison of global planning methods available in navigation stack. When I change global planner of move_base from navfn to carrot_planner I`m getting following error:

Failed to create the base_local_planner/TrajectoryPlannerROS planner, are you sure it is properly registered and that the containing library is built? Exception: MultiLibraryClassLoader: Could not create class of type base_local_planner::TrajectoryPlannerROS

[move_base-2] process has died

In order to change planning method I modified the launch file by including this line

<param name="base_global_planner" value="carrot_planner/CarrotPlanner"/>

Why is this happening?

edit retag flag offensive close merge delete

Comments

Precisely what parameter did you change?

David Lu gravatar imageDavid Lu ( 2013-09-20 07:25:44 -0500 )edit

I wanted to change global planner of move_base and i followed instructions included in this post http://answers.ros.org/question/39347/how-to-change-global-planner-of-move_base/?answer=39357#post-id-39357

babtu gravatar imagebabtu ( 2013-09-25 03:57:27 -0500 )edit

Go back a step. Does your launch file work if you don't include that line?

David Lu gravatar imageDavid Lu ( 2013-09-25 06:32:06 -0500 )edit

Yes, works like a charm. It also works when i set value to "navfn/NavfnROS" (default planner).

babtu gravatar imagebabtu ( 2013-09-25 10:22:37 -0500 )edit

I have the same problem. Works great by setting navfn/NavfnROS but dies when using carrot_planner/CarrotPlanner. I'm using ros-groovy.

fmder gravatar imagefmder ( 2013-10-04 04:08:51 -0500 )edit

I have the same problem. Have you solved it?

BP gravatar imageBP ( 2014-03-17 02:39:01 -0500 )edit

Same problem here. Carrot Planner works fine with dwa_local_planner, but I get the same error when trying to use it with base_local_planner.

IvanV gravatar imageIvanV ( 2014-10-14 08:30:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-10-04 10:34:55 -0500

David Lu gravatar image

updated 2013-10-04 10:35:09 -0500

A) Make sure all your planners are built. B) Try this launch file http://pastebin.com/FDxzwxaD (add your own map instead of some_package)

edit flag offensive delete link more

Comments

how do you build the planner?

aarontan gravatar imageaarontan ( 2018-06-13 14:36:31 -0500 )edit
David Lu gravatar imageDavid Lu ( 2018-06-13 14:49:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2013-09-19 02:08:33 -0500

Seen: 1,621 times

Last updated: Sep 19 '13