Ask Your Question
1

rqt loading with requested perspective

asked 2013-09-13 00:29:03 -0600

da-na gravatar image

updated 2013-11-14 11:03:51 -0600

tfoote gravatar image

Hi!

I'm having a problem with roslaunch rqt_gui rqt_gui. When I launch this command in terminal, only upper bar appears, then it disappears and appears again in different place, but the rqt_gui itself does not launch eventually. I believe it's connected to some plugin I wrote, though there are no error msgs in terminal. Is it possible to somehow run rqt_gui with requested perspective? I'd like to run rqt_gui with default perspective and try adding my plugin again, to see if it is the cause of my problem - now I'm not able to do anything in rqt.

Thanks in advance,

da-na

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
5

answered 2013-09-13 18:32:51 -0600

130s gravatar image

updated 2013-09-13 22:09:43 -0600

First, I believe you just put typo rosrun as roslaunch; roslaunching rqt_gui that doesn't have launch files shouldn't do anything.

You might want to look at help by $ rqt -h, that says a few options available regarding perspective:

  -p PERSPECTIVE, --perspective PERSPECTIVE
                        start with this named perspective
  --perspective-file PERSPECTIVE_FILE
                        start with a perspective loaded from a file
:  
  --list-perspectives   list available perspectives

If you want to reset all settings from previous runtime, run $ rqt --clear-config. Again from help:

  --clear-config        clear the configuration (including all perspectives and plugin settings)

Finally, you can ignite rqt_gui by just rqt as I did in the above.

edit flag offensive delete link more

Comments

1

Hey! Simply typing rqt doesn't work for me (there's a msg in terminal saying haven't found rqt command). But I typed "roscd rqt_gui/src" and then "./rqt_gui --clear-config" as you suggested. It worked :) Thank you Could anyone put this on tutorial page?

da-na gravatar imageda-na ( 2013-09-16 01:40:29 -0600 )edit

Hi. It worked also for me. In my case I had two click twice on the icon of my plugin for making it appear. Many thanks.

Gianluigi gravatar imageGianluigi ( 2013-10-08 06:00:49 -0600 )edit

@da-na looks like you're on fuerte where `rqt` command isn't there yet.

130s gravatar image130s ( 2013-10-08 12:34:10 -0600 )edit

@130s where does rqt save perspectives that can be called with the -p option?

2ROS0 gravatar image2ROS0 ( 2018-07-02 13:07:15 -0600 )edit

#q53861 might help.

130s gravatar image130s ( 2018-07-02 14:30:26 -0600 )edit
0

answered 2018-09-21 06:15:03 -0600

Edward gravatar image

And you can make smt like this in .launch file:

<launch>
  <node name = "my_rqt_dashboard" pkg = "rqt_gui" type = "rqt_gui" respawn = "false" output = "screen" args = "--perspective-fila $(find my_pkg_with_rqt_config)/rqt_config/my_dashboard.perspective"/>
</launch>
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-13 00:29:03 -0600

Seen: 2,643 times

Last updated: Sep 21 '18