ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Getting an error while installing Nao ros Stacks [closed]

asked 2013-05-05 18:40:47 -0600

supergeek256 gravatar image

So i have been following this Ros installation tutorial

and I seem to have run into this error several times as i have tried to set this up several times, any help?

This is the Error i recieve

matthew@U310:~/fuerte_workspace/nao$ rosdep install humanoid_msgs nao_robot nao_common ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: nao_teleop: Missing resource joy ROS path [0]=/opt/ros/fuerte/share/ros ROS path [1]=/home/matthew/ros_workspace/nao ROS path [2]=/home/matthew/ros_workspace/nao/stacks/nao_common ROS path [3]=/home/matthew/ros_workspace/nao/stacks/nao_robot ROS path [4]=/home/matthew/ros_workspace/nao/stacks/humanoid_msgs ROS path [5]=/opt/ros/fuerte/stacks ROS path [6]=/opt/ros/fuerte/share ROS path [7]=/opt/ros/fuerte/share/ros matthew@U310:~/fuerte_workspace/nao$

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Vincent Rabaud
close date 2014-08-01 06:27:48.604450


what is in your environment with respect to ROS env | grep ROS?

tfoote gravatar image tfoote  ( 2013-05-07 11:23:20 -0600 )edit

i get this as my environment

supergeek256 gravatar image supergeek256  ( 2013-05-07 19:01:54 -0600 )edit

ROS_ROOT=/opt/ros/fuerte/share/ros ROSLISP_PACKAGE_DIRECTORY=/opt/ros/fuerte/share/common-lisp/ros ROS_PACKAGE_PATH=/home/matthew/ros_workspace/nao/stacks/nao_common:/home/matthew/ros_workspace/nao/stacks/nao_robot:/home/matthew/ros_workspace/nao/stacks/humanoid_msgs:/opt/ros/fuerte/stacks:/opt/ros/

supergeek256 gravatar image supergeek256  ( 2013-05-07 19:02:27 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-05-27 08:00:13 -0600

supergeek256 gravatar image

So what ended up happening was i hadn't installed the joystick package, after that it worked fine so the answer is simply sudo apt-get joy

edit flag offensive delete link more

answered 2013-05-07 19:19:09 -0600

tfoote gravatar image

You will want to set ROS_DISTRO=fuerte for rosdep to know that you want fuerte packages.

edit flag offensive delete link more


I have my ROS_DISTRO set as fuerte

supergeek256 gravatar image supergeek256  ( 2013-05-09 11:29:20 -0600 )edit

Please edit your question to include the full environment. Your comment above doesn't show the ROS_DISTRO variable.

tfoote gravatar image tfoote  ( 2013-05-14 10:28:42 -0600 )edit

Question Tools


Asked: 2013-05-05 18:40:47 -0600

Seen: 275 times

Last updated: May 27 '13