Ask Your Question
2

Unable to locate package ros-fuerte-laser-drivers

asked 2013-09-07 03:38:03 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

hi guys i want to use hokuyo-04lx but when i write "sudo apt-get install ros-fuerte-laser-drivers" this error occured "Unable to locate package ros-fuerte-laser-drivers"

edit retag flag offensive close merge delete

Comments

Can we have some more information about how you have configured your system? Is there a reason you choose to use an older version of ROS for example?

Dereck gravatar imageDereck ( 2013-09-07 05:31:33 -0600 )edit

Hi Dereck I'm beginner in ros I just follow the Ubuntu install of ROS Hydro for Ubuntu 12.10

hamid gravatar imagehamid ( 2013-09-07 05:58:34 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2013-09-07 05:59:26 -0600

Dereck gravatar image

updated 2013-09-08 04:14:50 -0600

sudo apt-get install ros-hydro-urg-node

In a terminal (don't type the '$'): $ roscore

In another Terminal: $ rosrun urg_node urg_node

In another Terminal: $ rosrun rviz rviz

In rviz, you can use the 'add' button on the lower left of the screen to add a display I think you want to use pointcloud or pointcloud2 but you should be able click around and find what you need. Then you just need to set the topic for the display to /laserscan and rviz should show you the laserscan data on the screen.

This is all off the top of my head however, and I don't have that specific Hokuyo. Good luck!

edit flag offensive delete link more

Comments

1

Welcome to the wonderfully complex world of ROS. :) In hydro, the laser-drivers stack has been removed in favor or device specific packages, urg-node is the official driver for all Hokuyo devices.

Dereck gravatar imageDereck ( 2013-09-07 06:01:20 -0600 )edit

thanks a lot :)

hamid gravatar imagehamid ( 2013-09-07 06:57:19 -0600 )edit

On sites like this, you can say thanks by clicking the small check-circle to the left of a correct answer and 'up-voting' if you have enough reputation. :)

Dereck gravatar imageDereck ( 2013-09-07 07:04:52 -0600 )edit

hi again i test the laser scanner 04lx but this error occurd [rospack] Error: stack/package hokuyo_node not found

hamid gravatar imagehamid ( 2013-09-07 19:22:38 -0600 )edit

In Hydro hokuyo_node driver was replaced with urg_node.

Dereck gravatar imageDereck ( 2013-09-08 04:03:58 -0600 )edit

i write "rosrun urg_node urg_node" but this error occurd again [rospack] Error: stack/package urg_node not found what can i do?

hamid gravatar imagehamid ( 2013-09-08 18:42:56 -0600 )edit

Unfortunately, ROS is not like most applications where you can just figure things out by poking it. I highly recommend you take a week to do the tutorials listed @ http://wiki.ros.org/ROS/Tutorials They are terse, but will save you days of trouble. :)

Dereck gravatar imageDereck ( 2013-09-09 03:50:40 -0600 )edit

when i wrote "sudo apt-get install ros-hydro-urg-node"did it install the hokuyo pkg? for install hokuyo pkg should i do anything more?

hamid gravatar imagehamid ( 2013-09-09 04:00:54 -0600 )edit
0

answered 2014-09-03 17:06:46 -0600

hry gravatar image

Hi All,

I am new to ROS and as part of the tutorial, I was trying to install the hokuyo laser driver and have tried all the solutions posted in this forum so far but I keep getting the same error message

sudo apt-get install ros-fuerte-laser-drivers E: unable to locate package ros-fuerte-laser-drivers and sudo apt-get install ros-hydro-urg-node E: unable to locate package ros-hydro-urg-node

I am using Ubuntu 14.04 running on VirtualBox. I have ROS indigo igloo. Please help

edit flag offensive delete link more

Comments

Please ask this as a new question.

ahendrix gravatar imageahendrix ( 2014-09-03 17:20:12 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-09-07 03:38:03 -0600

Seen: 2,063 times

Last updated: Sep 08 '13