Problem compiling leg_detector [closed]

asked 2013-09-04 21:52:08 -0600

Rouno gravatar image

updated 2013-09-04 23:46:39 -0600

Hi folks,

I've git cloned the people stack from David Lu https://github.com/DLu/people to test his leg_detector but I'm facing a problem of compilation.

I tried a rosmake in both the stack folder and in the leg_detector package folder but there seems to be a problem with the people_tracking_filter library.

Here is the output of rosmake when I run it from the stack folder :

   Linking CXX executable ../bin/leg_detector
  /usr/bin/ld: cannot find -lpeople_tracking_filter
  collect2: ld returned 1 exit status
  make[3]: *** [../bin/leg_detector] Error 1
  make[3]: Leaving directory `/home/renauddidier/catkin_ws/src/people/leg_detector/build'
  make[2]: *** [CMakeFiles/leg_detector.dir/all] Error 2
  make[2]: Leaving directory `/home/renauddidier/catkin_ws/src/people/leg_detector/build'
  make[1]: *** [all] Error 2
  make[1]: Leaving directory `/home/renauddidier/catkin_ws/src/people/leg_detector/build'
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package leg_detector written to:
[ rosmake ]    /home/renauddidier/.ros/rosmake/rosmake_output-20130905-092242/leg_detector/build_output.log     
[rosmake-3] Finished <<< leg_detector [FAIL] [ 6.33 seconds ]                                                                                                                     
[ rosmake ] Halting due to failure in package leg_detector. 
[ rosmake ] Waiting for other threads to complete.                                                                   
[rosmake-1] Finished <<< face_detector [PASS] [ 6.95 seconds ]                                                                                                                    
[ rosmake ] Last 40 linescial_navigation_layers: 9.1 sec ]                                                                                             [ 1 Active 72/74 Complete ]

I'm running groovy on ubuntu 12.04.

Thank you very much

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by David Lu
close date 2013-09-05 05:05:49

Comments

I investigated a little bit further, tried to compile the people_tracking_filer package. It seems that cmake doens't work properly. This is what I got from the terminal : renauddidier@ubuntu:~/catkin_ws/src/people/people_tracking_filter/build$ cmake .. -- Configuring done -- Generating done -- Build files have been written to: /home/renauddidier/catkin_ws/src/people/people_tracking_filter renauddidier@ubuntu:~/catkin_ws/src/people/people_tracking_filter/build$ make make: *** No targets specified and no makefile found. Stop.

Rouno gravatar image Rouno  ( 2013-09-05 01:41:53 -0600 )edit

What is the output when running rosmake in people_tracking_filter?

David Lu gravatar image David Lu  ( 2013-09-05 04:31:34 -0600 )edit

Hi David, finally I tried to re clone from scratch and it compiled well. Don't know what was going on :) Anyway, thank you for your time. Is there anyone that could close this question please ?

Rouno gravatar image Rouno  ( 2013-09-05 04:51:53 -0600 )edit