Ask Your Question
0

Problem with leg_detector and people_tracking_filter

asked 2013-09-10 03:49:40 -0500

Rouno gravatar image

Hi ROS users !

I'd like to simulate a human wandering around with MORSE simulator and see the robot detecting it in rviz. I managed to install people stack from David Lu but got a couple of problems when I run it.

First I run filter.launch in people_tracking_filter package. Although I don't have any odom_combined frame as fixed frame, I replaced it with odom instead. /people_tracker_filter_visualization seems to be updated 10 times/s but is empty as shown with rostopic :

header: 
  seq: 375
  stamp: 
    secs: 0
    nsecs: 0
  frame_id: odom
points: []
channels: 
  - 
    name: rgb
    values: []

So I run leg_detector.launch is the corresponding package but I get the following error :

[ERROR] [1378816996.919008120]: Client [/people_tracker] wants topic /people_tracker_measurements to have datatype/md5sum [people_msgs/PositionMeasurement/54fa938b4ec28728e01575b79eb0ec7c], but our version has [people_msgs/PositionMeasurementArray/59c860d40aa739ec920eb3ad24ae019e]. Dropping connection.
[ WARN] [1378817011.705600206]: MessageFilter [target=/odom_combined ]: Dropped 100.00% of messages so far. Please turn the [ros.leg_detector.message_notifier] rosconsole logger to DEBUG for more information.

So second thing : the launch file refers to base_scan topic but mine is empty, every data is contained in my scan topic. However replacing base_scan by scan doesn't change anything. And also there is still some things related to odom_combined ...

Any guess ?

Thank you very much for your time.

I'm running groovy on ubuntu 12.04, MORSE 1.1 simulator with a differential robot and a 2D LIDAR.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-09-10 05:50:46 -0500

David Lu gravatar image

people_tracking_filter is a compile dependency for leg_detector, but you should be able to run leg_detector without launching filter.launch.

To be honest, I switched a bunch of stuff around with PositionMeasurements and PositionMeasurementArrays, and so I might have broken some components I don't use. Please try just running leg_detector.launch without the other launch file.

edit flag offensive delete link more

Comments

If I launch leg_detector alone it's OK but neither /people_tracker_measurements nor /leg_tracker_measurements are updated. However, I did noticed that the shape of the scan around the human avatar was a portion of a square. I guess this would explain why your package doesn't work. What do you think?

Rouno gravatar image Rouno  ( 2013-09-11 22:59:12 -0500 )edit

I'm not sure I understand. Do you think the squares should be detected as legs?

David Lu gravatar image David Lu  ( 2013-09-22 11:21:41 -0500 )edit

It seems that, in MORSE simulator, the human shape is contained in a box, and the laser rangefinder detects only this box and not the real shape of the legs. So, Rouno was asking if you think this can be the reason why it's not working well.

CarolineQ gravatar image CarolineQ  ( 2013-09-23 03:34:19 -0500 )edit

David, in which topic will the result be ? In /leg_tracker_measurements or /people_tracker_measurements ? I managed to have the markers in Rviz, but no people seem to be detected. Concerning the markers, what is the difference between blue, red and black markers ? Thanks

CarolineQ gravatar image CarolineQ  ( 2013-09-23 04:00:49 -0500 )edit
0

answered 2013-11-03 21:48:20 -0500

LucieR gravatar image

The problem with the people_tracking_filter is due to the loss of the compatibilty between this package and the leg_detector package. The messages sent by the leg_detector changed (PostionMeasurement -> PositionMeasurementArray) but it didn't change in the people_tracker_filter.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-09-10 03:49:40 -0500

Seen: 1,360 times

Last updated: Sep 10 '13