Ask Your Question
0

Problem with leg_detector in People: Dropped 100:00% message so far [closed]

asked 2014-12-29 08:33:01 -0500

scopus gravatar image

hi, all. I am trying to run leg_detector with indigo-devel branch which is a part of people in ROS wiki.
I found that "odom_combined" was set to be " fixed_frame" from source code. Following error is output. And no message is output both in topic /leg_tracker_measurements and /visualization_marker.

[ WARN] [1378817011.705600206]: MessageFilter [target=/odom_combined ]: Dropped 100.00% of messages so far. Please turn the [ros.leg_detector.message_notifier] rosconsole logger to DEBUG for more information.

I am using a Turtlebot2( i.e. kobuki) mounted with a hokuyo URG04LX.

Firstly, to solve this problem, I think the topic "odom_combined" is output by node "robot_pose_ekf". So I added "robot_pose_ekf" in launch file, but the problem still existed. Add since I am using Turtlebot2, the node "robot_pose_ekf" is confict with another node "mobile_base_nodelet_manager" which also manges the transform between "base_footprint" and "odom" in tf tree.

I also have changed "odom_combined" to be "laser_link" in all cpp and cfg files. And I deleted both devel and build directories and rebuild this workspace by running "catkin_make". The above error still existed.

Pleaase give me helpful advices. Thank you! @David Lu

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by scopus
close date 2015-01-03 19:41:31.019674

1 Answer

Sort by » oldest newest most voted
1

answered 2014-12-29 10:42:29 -0500

David Lu gravatar image

The leg detector translates all the laser readings into whatever the fixed_frame parameter is using a MessageFilter. If it can't translate them to that frame, it will give the error listed above.

For a turtlebot, you may want to set fixed_frame to just odom.

edit flag offensive delete link more

Comments

Thank you. It is ok if fixed_frame is set to be "odom". However, I stil wonder that why "laser_link" is not ok,since this is associated to laser itself which is used for detecting legs. By running "rosrun tf tf_echo /odom /laser_link", there exists transfrom between /odom and /laser_link. Thanks!

scopus gravatar image scopus  ( 2014-12-29 19:52:04 -0500 )edit

Because of how dynamic reconfigure works, you may have also needed to change the .cfg file.

David Lu gravatar image David Lu  ( 2014-12-29 20:15:35 -0500 )edit

I have also modified "fixed_frame' in .cfg file to be "laser_link". But it failed still.

scopus gravatar image scopus  ( 2014-12-30 06:51:00 -0500 )edit

Is this still a problem, now that you've changed the frame to odom?

David Lu gravatar image David Lu  ( 2014-12-30 09:11:40 -0500 )edit

It works now with "odom". I mean the "fixed_frame" both in cpp files and cfg file were changed to be "laser_link". then the package was re-built. In this case, it didn't work. I wonder why it failed with "laser_link". Thank you and Happy new year to you!

scopus gravatar image scopus  ( 2014-12-30 22:04:02 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-12-29 08:33:01 -0500

Seen: 1,178 times

Last updated: Dec 29 '14