Ask Your Question
0

no sensor_msgs/MagneticField Illuminance?

asked 2013-08-21 04:12:36 -0500

rem870 gravatar image

updated 2013-08-23 03:20:30 -0500

HI

i want to use a sensor_msgs/MagneticField and sensor_msgs/Illuminance type message but my distribution (fuerte) don't have those types. (i checked the file sensor_msgs/msg) so i get the error ERROR: Cannot load message class for [sensor_msgs/Illuminance]. Are your messages built?

my messages are built, in fact i used from the same topic the sensor_msgs/imu

what should i do?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-08-21 06:17:55 -0500

dornhege gravatar image

You could make an overlay of the sensor_msgs package using the groovy one in your fuerte build. Under the assumption that the older messages weren't changed, this should be OK, but everyone using this would need the same overlay.

The alternative is to define those messages yourself for your fuerte build (as a custom package)

Which is better depends on what you plan to do. If you want to connect to a groovy system, the first way would be better.

edit flag offensive delete link more

Comments

what do you mean :define those messages yourself for your fuerte build.??? here:http://www.ros.org/wiki/sensor_msgs in the fuerte there is illuminance and magnetic field. i have reinstalled sensor_msgs but its the same.

rem870 gravatar image rem870  ( 2013-08-21 07:07:09 -0500 )edit

i have downloaded common_msgs and inside the sensor_msgs have pasted the 2 msgs that i want, i also have added them in the cmake but when i type rosmake i get that there is no makefile, i added a makefile, everything compiled but i still get the same message.

rem870 gravatar image rem870  ( 2013-08-21 07:48:36 -0500 )edit

should i delete the sensor_msgs that are on my fuerte/share?

rem870 gravatar image rem870  ( 2013-08-21 08:09:08 -0500 )edit

No, you just need to overlay them correctly, so that roscd sensor_msgs points to that. With define I meant: Make some package on your own. -- As to the wiki, I think that might just be wrong. If you go to the auto-generated code-api the messages aren't in groovy.

dornhege gravatar image dornhege  ( 2013-08-21 23:00:09 -0500 )edit

still not working. i type roscd sensor_msgs it points to my package but still not working

rem870 gravatar image rem870  ( 2013-08-22 08:55:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-21 04:12:36 -0500

Seen: 846 times

Last updated: Aug 23 '13