katana arm timing problems [closed]

asked 2013-08-06 03:23:32 -0600

rem870 gravatar image

updated 2013-08-13 01:13:50 -0600

BennyRe gravatar image

Hi

i set a path to the katana using ROS, that is consisted of 11 points +the starting point, that should take 11 sec. instead it takes 15 secs ,why is that.

as a result of this delay the robot does not reach the desired velocity - acceleration that i want (these are lower than the max vel and max acc)

what should i do?

thanks

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-04-27 02:00:55.875616

Comments

Could you please post the code, where you set up this trajectory?

BennyRe gravatar imageBennyRe ( 2013-08-13 01:16:14 -0600 )edit

the source code is actually too big. i use katana_tutorials follow_joint_trajectory_client.

rem870 gravatar imagerem870 ( 2013-08-13 21:31:33 -0600 )edit

Are you sure the Katana can perform this trajectory in 11 seconds? Which Katana type do you use?

BennyRe gravatar imageBennyRe ( 2013-08-13 21:54:54 -0600 )edit

yes i am sure. the trajectory that i wanted does not exceed the limits of acceleration or velocity

rem870 gravatar imagerem870 ( 2013-08-13 22:17:24 -0600 )edit

What happens if you make the trajectory longer? Is the performed trajectory even longer or is the time it took the correct? Which Katana do you use?

BennyRe gravatar imageBennyRe ( 2013-08-13 22:26:29 -0600 )edit

i use katana_450_6m90a . i haven't tried a longer trajectory, if i try to make it shorter then i get an error that it cannot make a trajectory (probably because it exceeds the max acc,vel)

rem870 gravatar imagerem870 ( 2013-08-13 22:38:13 -0600 )edit