Neuronics Katana Arm: FirmwareException: 'CRC does not match'

asked 2014-12-17 15:31:06 -0600

tufail gravatar image

Hi,

I have a Neuronics Katana Arm (400, 6M180) and I am using the ROS package uos-ros-pkg for application development. I have noticed when I try to send the target pose (position + orientation) to the arm from MATLAB (via KNI_wrapper), the arm doesn't move and I get the error that says "FirmwareException: CRC does not match". Sending the target encoders values to the arm execute fine and without any error.

Today I tried on it the "follow_joint_trajectory" tutorial (katana_tutorials in uos-ros-pkg), I get the same error which means the problem is with the hardware not the software.

My question is that has anyone encountered a similar problem? Have you tried to update the firmware? Where can I get the updated firmware files from as the company's website is up no more. Will it solve the problem? If it won't, can I recover the original firmware back?

Complete description of the error is as follows:

ial@ial-SONY:~$ roslaunch katana katana.launch

logging to /home/ial/.ros/log/08aa7634-8631-11e4-94d4-f0bf971cd83f/roslaunch-ial-SONY-17613.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ial-SONY:51284/

SUMMARY
========

PARAMETERS
 * /katana/config_file_path
 * /katana_gripper_joints
 * /katana_joints
 * /katana_type
 * /robot_description
 * /rosdistro
 * /rosversion

NODES
  /
    katana (katana/katana)
    robot_state_publisher (robot_state_publisher/state_publisher)

auto-starting new master
process[master]: started with pid [17632]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 08aa7634-8631-11e4-94d4-f0bf971cd83f
process[rosout-1]: started with pid [17645]
started core service [/rosout]
process[robot_state_publisher-2]: started with pid [17657]
process[katana-3]: started with pid [17674]
[ INFO] [1418850589.843614312]: trying to connect to katana (TCP/IP) on 192.168.168.232:5566...
[ INFO] [1418850589.845436881]: success: TCP/IP connection to Katana opened
[ INFO] [1418850589.845519648]: success: protocol class instantiated
[ INFO] [1418850589.845583525]: success: communication with Katana initialized
[ INFO] [1418850589.980629183]: success: katana initialized
[ INFO] [1418850590.540611503]: no calibration required
[ INFO] [1418850590.540711165]: success: katana calibrated
[ INFO] [1418850590.883426110]: katana gripper grasp query service started on topic /gripper_grasp_status
[ INFO] [1418850590.895750683]: katana gripper grasp hand posture action server started on topic /gripper_grasp_posture_controller
[ INFO] [1418850601.349945571]: Sending trajectory to Katana arm...
Error flag received:
[ERROR] [1418850601.820043052]: FirmwareException: Motor collision? Perhaps we tried to send a trajectory that the arm couldn't follow. (exception in executeTrajectory(): FirmwareException : 'CRC does not match
')
[ERROR] [1418850601.820121784]: Problem while transferring trajectory to Katana arm, aborting
^C[katana-3] killing on exit
[robot_state_publisher-2] killing on exit
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

Thanks and looking forward to any suggestions.

edit retag flag offensive close merge delete