Ask Your Question
2

No kinect connected...waiting for devices to be connected...

asked 2013-07-20 19:27:08 -0500

FourTrees gravatar image

updated 2016-10-24 09:09:55 -0500

ngrennan gravatar image

I use Ubuntu 12.04.02 LTS , and ROS fuerte. but if I press 'roslaucnh openni_launch openni.launch', no device connected...... How can I solve this situation???

UPDATE

rostopic list result

turtlebot@turtlebot-AO756:~$ rostopic list 
/cmd_vel 
/diagnostics 
/diagnostics_agg 
/diagnostics_toplevel_state 
/imu/data 
/imu/raw 
/joint_states 
/laptop_charge 
/odom 
/robot_pose_ekf/odom 
/rosout 
/rosout_agg 
/tf 
/turtlebot/app_list 
/turtlebot/application/app_status 
/turtlebot_node/parameter_descriptions 
/turtlebot_node/parameter_updates 
/turtlebot_node/sensor_state 
turtlebot@turtlebot-AO756:~$

ros version is fuerte , ubuntu version is 12.04

and i robot create's kinect status light is red.

I don't know what is the problem.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
5

answered 2013-07-20 22:06:56 -0500

updated 2013-07-20 22:08:27 -0500

Hi @FourTrees,

This could be a classic error I have faced before because of the process XnSensorServer.

It would be more useful if you can also share with us the output for

rostopic list

However, I can suggest you a possible solution (way around) which might just work. You need to basically restart the XnSensorServer Process. This can be done using the following two lines of command:

killall XnSensorServer

XnSensorServer

After performing this try to roslaunch the openni.launch file. Let us know if this works. Just to add to your information this happens when you launch openni topics multiple times as sometimes the XnSensorServer process is not properly cleared and shutdown.

Please note that if you have the process XnSensorServer linked to any other program or doing something else killing the process may not be a safe choice. It is advisable to kill/ Terminate any other processes using XnSensorServer before killing this process.

GoodLuck,

Regards,

Sivam

edit flag offensive delete link more

Comments

2

In addition to above workaround, there is a possibility that your kinect is not powered although it might be connected to robot you are working on...but direct power supply should also be there... For this make sure yellow light glows on Kinect..

Devasena Inupakutika gravatar image Devasena Inupakutika  ( 2013-07-20 23:05:29 -0500 )edit

Also, in case above step has been followed, Please check if your robot is charged. Please do check the output of lsusb once and you can refer this too: http://answers.ros.org/question/12107/kinect-no-devices-connected-on-openni_nodelaunch/

Devasena Inupakutika gravatar image Devasena Inupakutika  ( 2013-07-20 23:06:35 -0500 )edit
1

I have a follow-up question. I can get my Linux 12.04 with ROSHydro system to run two kinects perfectly fine, but when I try to launch the 3rd it comes up with an error that says "Application XnSensorSever has closed unexpectedly". These Kinects are all on different buses btw. Any ideas?

Athoesen gravatar image Athoesen  ( 2013-11-06 05:12:01 -0500 )edit

Hydro, openni_launch, No kinect connected...waiting for devices to be connected... Solution: sudo apt-get remove libopenni-* sudo apt-get install libopenni-* download the openni_launch again. And then it works!

Gloria@HK gravatar image Gloria@HK  ( 2014-06-19 05:25:32 -0500 )edit
2

answered 2015-01-07 12:49:15 -0500

gaussian gravatar image

This is the best solution i could ever come up with.

Go to synaptic manager and reinstall all the openni packages.

Avin2 GitHub snapshot of SensorKinect drivers - look in Bin folder and use the package relevant to your OS to install the driver.

Then install NITE 1.5.2.21 driver present here

Now run openni_launch that run runs without any error and then run openni_tracker for skeleton tracking.

edit flag offensive delete link more
0

answered 2014-01-13 00:15:45 -0500

kleinsplash gravatar image

updated 2014-01-17 01:43:54 -0500

I have had similar problems before. The killall XnSensorServer typically works if you cant get your openni device running a second time (kinect or asus) but the "No devices connected.... waiting for devices to be connected" for me was a permissions issue with the usb port. So find the bus port that your camera is connected to and make sure that it has read write permissions.

Edit: Solved!! I had to reinstall my libopenni - which I did through synaptic - now I dont get the error and I dont have to kill XnSensorServer every time I restart.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-20 19:27:08 -0500

Seen: 7,357 times

Last updated: Jan 07 '15