Ask Your Question
0

knowrob_gui Exception

asked 2013-07-17 04:38:09 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

when I run the knowrob_gui, a exception occurred:
Exception in thread "Animation Thread" java.lang.UnsatisfiedLinkError: /opt/ros/groovy/stacks/knowrob/3rdparty/jpl/jpl/libjpl.so: libswipl.so.5.10.4: cannot open shared object file: No such file or directory at java.lang.ClassLoader$NativeLibrary.load(Native Method) at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1750) at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1675) at java.lang.Runtime.loadLibrary0(Runtime.java:840) at java.lang.System.loadLibrary(System.java:1047) at jpl.JPL.loadNativeLibrary(JPL.java:100) at jpl.fli.Prolog.<clinit>(Prolog.java:85) at edu.tum.cs.ias.knowrob.prolog.PrologInterface.initJPLProlog(PrologInterface.java:33) at jp.atr.unr.pf.gui.KnowRobGuiMain.setup(KnowRobGuiMain.java:68) at processing.core.PApplet.handleDraw(Unknown Source) at processing.core.PApplet.run(Unknown Source) at java.lang.Thread.run(Thread.java:679)

@moritz

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-07-17 04:49:17 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

That's a linker problem, does the file exist? For me, it's at /usr/lib/libswipl.so.5.10.4

Files in /lib and /usr/lib are normally found without adding the directory to the LD_LIBRARY_PATH; in case you get other java-related linker issues, you may need to set

export LD_LIBRARY_PATH=/usr/lib/jvm/default-java/jre/lib/i386:/usr/lib/jvm/default-java/jre/lib/i386/server

edit flag offensive delete link more

Comments

Thanks Moritz!:-) I found the new version /usr/lib/libswipl.so.6.3.19 and exported the path as you said. And I re-compile knowrob and knowrob_gui. The error is still there.

Rikardo gravatar image Rikardo  ( 2013-07-17 05:16:23 -0500 )edit

The same error or the equivalent with "libswipl.so.6.3.19"? In the former case, I'd try a 'rosmake --pre-clean knowrob_gui' to make sure that no outdated code remains.

moritz gravatar image moritz  ( 2013-07-17 05:22:51 -0500 )edit

It is the same error which need libswipl.so.5.10.4. I see. Is this the problem with the different version of swi-prolog. Shall I compile and install a previous version of swi-prolog. Otherwise, a better solution to this. BTW, the tutorial for installation on knowrob website dose not work in groovy.

Rikardo gravatar image Rikardo  ( 2013-07-17 05:28:40 -0500 )edit

with rosws merge [...], we can not have permission to download the code. I can git clone the code and compile by myself. But to compile each package one by one is a huge work, especially to compile the knowrob_addons.

Rikardo gravatar image Rikardo  ( 2013-07-17 05:32:03 -0500 )edit

You should not need to install Prolog from source. The error message says that libjpl.so in the jpl package is compiled against Prolog 5.10.4. Please try the rosmake --pre-clean to make sure it's re-built against the new version. Have you updated Ubuntu to a new version recently?

moritz gravatar image moritz  ( 2013-07-17 05:57:37 -0500 )edit

Why doesn't rosws work? knowrob and knowrob_addons are public and we use rosws for installing it. Even if you have to check out the repository by yourself, you don't have to compile each package, rosmake compiles all dependent packages automatically.

moritz gravatar image moritz  ( 2013-07-17 06:00:36 -0500 )edit

Thanks again. I installed knowrob and swi-prolog by apt-get. I have already used rosmake --pre-clean to compile. I still use ubuntu 12.04. But the problem is still the same. Shall I install knowrob by source code?

Rikardo gravatar image Rikardo  ( 2013-07-17 06:03:43 -0500 )edit

I recommend installation from source, the .deb packages have another problem with OWL files that I haven't solved yet. We also use Ubuntu 12.04, but it includes SWI Prolog 5.10.4, so the link should be correct. You haven't installed a newer version by yourself?

moritz gravatar image moritz  ( 2013-07-17 06:08:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-17 04:38:09 -0500

Seen: 246 times

Last updated: Jul 17 '13