Ask Your Question
0

Problem with the semantic_map editor knowrob_gui running

asked 2013-07-12 07:12:40 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

As the semantic map editor is moved into knowrob_gui. But the tutorial and document has not been updated. Do anyone know what is the problem with this:

When I compiled the knowrob_gui successfully in groovy on Ubuntu 12.04 and run it

$rosrun knowrob_gui KnowRobGUI

It displays that:

find: ‘/jre/lib/’: No such file or directory Cannot find libjsig ... maybe you need to set JAVA_HOME?

It is not clear in the tutorial in knowrob org

PS: @moritz would you please update the tutorial if possible?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2013-07-14 23:01:08 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Well, the error message is rather clear, you need to set the JAVA_HOME environment variable. Google helps how to do this:

export JAVA_HOME=/usr/lib/jvm/default-java

You can either enter this command in the shell or add it to your ~/.bashrc to have it set automatically in every newly opened shell.

edit flag offensive delete link more

Comments

Thanks, I set the JAVA_HOME at first but not work. I re-installed a new system and it is OK, but new error occurred. It says [FATAL ERROR Could not find system resources

Rikardo gravatar image Rikardo  ( 2013-07-17 00:31:23 -0500 )edit

Try setting the SWI_HOME_DIR environment variable as indicated here: http://www.swi-prolog.org/FAQ/FindResources.html

export SWI_HOME_DIR=/usr/lib/swi-prolog

moritz gravatar image moritz  ( 2013-07-17 00:56:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-12 07:12:40 -0500

Seen: 147 times

Last updated: Jul 14 '13