ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Unable to load existing OWL in Semantic Map Editor

asked 2014-02-23 21:54:54 -0500

Albert K gravatar image

updated 2014-02-27 18:30:58 -0500

When I tried to load and existing OWL file in Semantic Map Editor, the console output the following messages and just stuck there :

Feb 14, 2014 2:03:01 PM controlP5.ControlBroadcaster printMethodError
SEVERE: An error occured while forwarding a Controller event, please check your code at controlEvent
    at sun.reflect.GeneratedMethodAccessor6.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    at java.lang.reflect.Method.invoke(
    at controlP5.ControlBroadcaster.invokeMethod(Unknown Source)
    at controlP5.ControlBroadcaster.broadcast(Unknown Source)
    at controlP5.Controller.broadcast(Unknown Source)
    at controlP5.Button.setValue(Unknown Source)
    at controlP5.Button.activate(Unknown Source)
    at controlP5.Button.mouseReleased(Unknown Source)
    at controlP5.Controller.setMousePressed(Unknown Source)
    at controlP5.ControllerGroup.setMousePressed(Unknown Source)
    at controlP5.ControlWindow.mouseReleasedEvent(Unknown Source)
    at controlP5.ControlWindow.mouseEvent(Unknown Source)
    at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    at java.lang.reflect.Method.invoke(
    at processing.core.PApplet$RegisteredMethods.handle(Unknown Source)
    at processing.core.PApplet.handleMouseEvent(Unknown Source)
    at processing.core.PApplet.dequeueMouseEvents(Unknown Source)
    at processing.core.PApplet.handleDraw(Unknown Source)
    at Source)
Caused by: jpl.PrologException: PrologException: error(existence_error(procedure, /(rdf_has, 3)), context(:(system, /('<meta-call>', 1)), _27))
    at jpl.Query.get1(
    at jpl.Query.hasMoreSolutions(
    at jpl.Query.oneSolution(
    at jpl.Query.hasSolution(
    at edu.tum.cs.ias.knowrob.prolog.PrologInterface.executeQuery(
    at edu.tum.cs.ias.knowrob.vis.applets.SemanticMapVisApplet.getItem(
    at edu.tum.cs.ias.knowrob.vis.applets.SemanticMapVisApplet.addObject(
    ... 22 more

What might be the cause and how to solve it? Thanks~



New error messages:

%     library(error) compiled into error 0.01 sec, 18,352 bytes
%    library(lists) compiled into lists 0.01 sec, 44,824 bytes
%   library(shlib) compiled into shlib 0.01 sec, 65,920 bytes
%   library(option) compiled into swi_option 0.00 sec, 14,752 bytes
ERROR: /usr/lib/swi-prolog/library/
    '$open_shared_object'/3: /usr/lib/swi-prolog/lib/amd64/ undefined symbol: Sfilefunctions
Warning: /usr/lib/swi-prolog/library/
    Goal (directive) failed: process:use_foreign_library(foreign(process))
ERROR: /usr/lib/swi-prolog/library/
    Exported procedure process:process_wait/3 is not defined
ERROR: /usr/lib/swi-prolog/library/
    Exported procedure process:process_kill/2 is not defined
%  library(process) compiled into process 1.14 sec, 97,120 bytes
% /opt/ros/groovy/stacks/knowrob/rosprolog/prolog/ compiled 1.14 sec, 109,432 bytes
jpl.PrologException: PrologException: error(existence_error(procedure, :(process, /(process_create, 2))), context(:(process, /(process_create, 3)), _0))
    at jpl.Query.get1(
    at jpl.Query.hasMoreSolutions(
    at jpl.Query.oneSolution(
    at edu.tum.cs.ias.knowrob.prolog.PrologInterface.initJPLProlog(
    at ...
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2014-03-05 03:56:36 -0500

moritz gravatar image

OK, so I've tested in my setup. What works for me is to call `export; rosrun knowrob_gui KnowRobGUI` and to load the demo-map.owl. It looks like this

edit flag offensive delete link more


Sorry for the late reply. Here's the output message when I run the program using the above command: . When I load the demo-map.owl, I get additional output: "% Loaded "demo-map.owl" in 0.00 sec; 192 triples" on the terminal, but there's still nothing shown in the program.

Albert K gravatar image Albert K  ( 2014-03-12 17:33:36 -0500 )edit

answered 2014-02-26 22:04:24 -0500

moritz gravatar image

This line PrologException: error(existence_error(procedure, /(rdf_has, 3)) indicates that something important went wrong with starting KnowRob. Are you sure that you have setup KnowRob correctly according to the instructions here?

edit flag offensive delete link more


Since I use ROS Groovy, I simply install it with: sudo apt-get install ros-groovy-knowrob The environment variable JAVA_HOME and SWI_HOME_DIR are also set. The error message became a little bit different. I've updated it in the original post

Albert K gravatar image Albert K  ( 2014-02-27 18:25:52 -0500 )edit

The .deb packages are broken, so please install from source using the instructions I've sent you.

moritz gravatar image moritz  ( 2014-02-27 19:56:16 -0500 )edit

I followed the document and installed it from source successfully. When I tried to load this owl:, I got errors like "item '' not found" Anything went wrong? Thanks

Albert K gravatar image Albert K  ( 2014-03-03 04:56:11 -0500 )edit

Sorry for the ambiguous description. Let me make it clear. When I "rosrun mod_semantic_map SemanticMapEditor", I get "Error: Could not find or load main class" and program terminated.

Albert K gravatar image Albert K  ( 2014-03-04 16:46:49 -0500 )edit

When I "rosrun knowrob_gui KnowRobGUI", I get the following output messages: and a window popped up. When I try to load this owl:, I get the following messages: and nothing shows up in the program.

Albert K gravatar image Albert K  ( 2014-03-04 16:51:20 -0500 )edit

Where did you find a reference on mod_semantic_map? That has long been replaced by knowrob_gui, and I thought all references have been updated.

moritz gravatar image moritz  ( 2014-03-05 03:42:22 -0500 )edit

I found the mod_semantic_map reference a few years ago, using ROS Fuerte. I was just starting to learn ROS at that time, so I collect many programs that I can run and look cool, and make a list of them. The mod_semantic_map is one of them.

Albert K gravatar image Albert K  ( 2014-03-12 17:37:39 -0500 )edit

Question Tools

1 follower


Asked: 2014-02-23 21:54:54 -0500

Seen: 712 times

Last updated: Feb 27 '14