Ask Your Question
0

catkin_make package not found

asked 2013-06-27 01:14:20 -0500

updated 2013-06-27 07:23:07 -0500

William gravatar image

Hi guys,

I'm trying to follow this tutorial http://www.ros.org/wiki/navigation/Tutorials/RobotSetup/TF but after I catkin_make the package with this output:

Base path: /home/master/catkin_ws
Source space:
/home/master/catkin_ws/src Build
space: /home/master/catkin_ws/build
Devel space:
/home/master/catkin_ws/devel Install
space: /home/master/catkin_ws/install
####
#### Running command: "make cmake_check_build_system" in
"/home/master/catkin_ws/build"
####

-- Using CATKIN_DEVEL_PREFIX: /home/master/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/groovy
-- This workspace overlays: /opt/ros/groovy
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- Using CATKIN_TEST_RESULTS_DIR: /home/master/catkin_ws/build/test_results

-- catkin 0.5.65
-- BUILD_SHARED_LIBS is on
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 1 packages in topological order:
-- ~~  - robot_setup_tf
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'robot_setup_tf'
-- ==> add_subdirectory(robot_setup_tf)
-- Configuring done
-- Generating done
-- Build files have been written to: /home/master/catkin_ws/build
####
#### Running command: "make -j1 -l1" in "/home/master/catkin_ws/build"
####

but when I try

rosrun robot_setup_tf tf_broadcaster

the sheel output is:

[rosrun] Couldn't find executable
named tf_broadcaster below
/catkin_ws/build/robot_setup_tf/catkin_generated/stamps/robot_setup_tf

I'm a newbie in source devoloping soo I don't know what I'm doing wrong, thanks in advance for any help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-06-27 05:17:07 -0500

It looks to me as if your $ROS_PACKAGE_PATH environment variable is set wrong. ROS should be looking in /home/master/catkin_ws/devel, not the build directory for your executables.

Did you remember to source the devel/setup.bash file to add the catkin workspace to your ROS_PACKAGE_PATH? More info at the bottom of this tutorial.

$ source devel/setup.bash
edit flag offensive delete link more

Comments

thanks a lot, it works, but now the other packages are not found. I create the catkin_ws inside the $ROS_PACKAGE_PATH and I don't remember how to set both path as ROS_PACKAGE_PATH.Could you help me one more time?

danielq gravatar imagedanielq ( 2013-06-27 08:48:06 -0500 )edit

@danielq Please ask a full new question so that it can stand on it's own and help others with the new problem you have.

tfoote gravatar imagetfoote ( 2013-06-27 08:49:27 -0500 )edit

thanks for the suggestion @tfoote , I will do it.

danielq gravatar imagedanielq ( 2013-06-27 09:02:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-27 01:14:20 -0500

Seen: 5,755 times

Last updated: Jun 27 '13