RobotSetup tf: Can't build in Catkin_make

asked 2018-03-19 20:01:25 -0600

HY gravatar image

updated 2018-03-19 23:16:39 -0600

catkin_make

Base path: /home/hy/catkin_ws

Source space: /home/hy/catkin_ws/src

Build space: /home/hy/catkin_ws/build

Devel space: /home/hy/catkin_ws/devel

Install space: /home/hy/catkin_ws/install ####

Running command: "make cmake_check_build_system" in "/home/hy/catkin_ws/build"

#### ####

Running command: "make -j4 -l4" in "/home/hy/catkin_ws/build"

#### hy catkin_ws $ catkin_make Base path: /home/hy/catkin_ws Source space: /home/hy/catkin_ws/src Build space: /home/hy/catkin_ws/build Devel space: /home/hy/catkin_ws/devel Install space: /home/hy/catkin_ws/install ####

Running command: "make cmake_check_build_system" in "/home/hy/catkin_ws/build"

#### ####

Running command: "make -j4 -l4" in "/home/hy/catkin_ws/build"

#### make[2]: * No rule to make target 'robot_setup_tf/CMakeFiles/tf_broadcaster.dir/build'. Stop.

CMakeFiles/Makefile2:2592: recipe for target 'robot_setup_tf/CMakeFiles/tf_broadcaster.dir/all' failed

make[1]: * [robot_setup_tf/CMakeFiles/tf_broadcaster.dir/all] Error 2

make[1]: * Waiting for unfinished jobs....

[ 8%] Built target tf_listener

[ 8%] Built target _axon_link_generate_messages_check_deps_AxonApp

[ 8%] Built target _axon_link_generate_messages_check_deps_AxonNode Makefile:138: recipe for target 'all' failed make: * [all] Error 2 Invoking "make -j4 -l4" failed

Above is the error displayed in the command prompt terminal. I was trying the navigation tutorial (building tf)

http://wiki.ros.org/navigation/Tutori...

Thanks

edit retag flag offensive close merge delete

Comments

1

Please provide enough context for us to reproduce your issue. You appear to have a CMake issue but without your CMake included it's hard to suggest any changes. Please edit your question to have enough context to reproduce your issue. http://wiki.ros.org/Support

tfoote gravatar imagetfoote ( 2018-03-19 20:33:15 -0600 )edit

Thanks for replying. I had it worked out now. I think the solution is to close all terminals and restart the terminal.

HY gravatar imageHY ( 2018-03-19 23:24:15 -0600 )edit