Ask Your Question
0

Mixing pcl versions inside ros?

asked 2013-06-12 03:01:00 -0600

dberm22 gravatar image

updated 2014-04-20 14:09:25 -0600

ngrennan gravatar image

I am trying to use RegionGrowingRGB and other functions which are available in pcl 1.7 but not 1.5. The issue I am having is that 1.7 does not contain the recent patch that was applied to 1.5 (which solved my segfault issue here).

My question is, is there any way I can mix versions in my code? I either want to use 1.5 but be able to call functions implemented in 1.7, or use 1.7 but be able to use the 1.5 version of files which were affected by the patch. Is there any easy way to do this?

I don't think I can simply copy the missing files into the 1.5 directory because I'm sure there are tons of dependencies.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-06-12 10:49:58 -0600

mjcarroll gravatar image

updated 2013-06-12 10:50:20 -0600

If you are trying to use functionality that is only in PCL 1.7, then it is probably in your best interest to apply the patch from your other question to PCL 1.7 and just use that.

I'm going to guess that it will be significantly easier to fix the bug in 1.7 and build from source than it will be to backport all of the functionality to 1.5.

edit flag offensive delete link more

Comments

I was able to get it working by backporting the functions from 1.7 into 1.5. Hopefully there will be a patch to 1.7 before I need to backport any more functions. Thanks anyway.

dberm22 gravatar imagedberm22 ( 2013-06-13 10:01:02 -0600 )edit

@dberm22! How did you do that?

Shashwat gravatar imageShashwat ( 2014-09-18 09:25:13 -0600 )edit
1

answered 2013-06-12 22:41:32 -0600

You should read http://www.ros.org/wiki/pcl17 and use https://github.com/ros-perception/perception_pcl/tree/fuerte-unstable-devel.

And if you have any issues with this ros package, then report your problems.

edit flag offensive delete link more

Comments

I said in my post that I tried 1.7. I updated it 2 days ago..the patch is not applied, so it doesn't work.

dberm22 gravatar imagedberm22 ( 2013-06-13 06:11:00 -0600 )edit
1

Can you give me a link to the patch you talking about? To my knowledge there wasn't any significant change. The problem was just the compiler optimization on the build farm. But I'm wondering if you compile pcl 1.7 yourself, why do you get a "Illegal instruction" error?

MichaelKorn gravatar imageMichaelKorn ( 2013-06-13 23:57:32 -0600 )edit
1

https://github.com/ros-gbp/pcl-fuerte-release/commit/1f5e5905b89005fd0e2ffc788eb991900fc9de99 , I think this was all. And this shouldn't make a difference if you compile pcl1.7 yourself.

MichaelKorn gravatar imageMichaelKorn ( 2013-06-14 00:08:57 -0600 )edit

I wasn't sure if that flag was the only difference, so I didn't take the time to download the new source, edit the file, and then recompile myself. Plus, my laptop is a brand new aienware with SSE support...so I have no idea if it'll help.

dberm22 gravatar imagedberm22 ( 2013-06-14 01:30:19 -0600 )edit

Yup, downloading the source, editing the cmake files to not include those checks, and recompiling did the job. Not sure why those flags should matter as my pcl is sse compatible, but either way, it's working.

dberm22 gravatar imagedberm22 ( 2013-06-14 03:31:02 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-12 03:01:00 -0600

Seen: 171 times

Last updated: Jun 12 '13