Ask Your Question
5

PCL error in ROS fuerte

asked 2013-06-07 00:04:20 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

mkdir -p bin

cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=rospack find osbuild/rostoolchain.cmake .. [rosbuild] Building package New [rosbuild] Cached build flags older than manifests; calling rospack to get flags

Failed to invoke /opt/ros/fuerte/bin/rospack cflags-only-I;--deps-only New CMake Error at /usr/lib/vtk-5.8/VTKTargets.cmake:16 (ADD_EXECUTABLE): Command add_executable() is not scriptable

Call Stack (most recent call first): /usr/lib/vtk-5.8/VTKConfig.cmake:231 (INCLUDE) /usr/share/cmake-2.8/Modules/FindVTK.cmake:73 (FIND_PACKAGE) /opt/ros/fuerte/stacks/perception_pcl/pcl/vtk_include.cmake:1 (find_package)

CMake Error at /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:129 (message):

Failed to invoke rospack to get compile flags for package 'New'.  Look
above for errors from rospack itself.  Aborting.  Please fix the broken
dependency!

Call Stack (most recent call first): /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:227 (rosbuild_invoke_rospack) CMakeLists.txt:12 (rosbuild_init)


I am facing this error to compile my packages. Can anybody help me. I am using Ubuntu 12.04. ROS fuerte.

edit retag flag offensive close merge delete

Comments

1

same issue here too

sai gravatar image sai  ( 2013-06-07 05:12:01 -0500 )edit

Seeing the same as well when compiling husky_simulator in fuerte on 12.04. The same package on the same machine works fine in groovy.

abencz gravatar image abencz  ( 2013-06-07 05:44:53 -0500 )edit
2

This is effecting gazebo plugins compilation as well, since gazebo seems depends on perception_pcl. Seem to be broken by a Ubuntu update this week.

yanma gravatar image yanma  ( 2013-06-07 05:47:05 -0500 )edit
1

thats true, after update, the package is not compiling, pls post the answer once you solve the issue

sai gravatar image sai  ( 2013-06-07 05:52:59 -0500 )edit

Same problem with laser_scan_matcher ...

martimorta gravatar image martimorta  ( 2013-06-10 00:57:02 -0500 )edit

would be great if one of you could post a bug report on github and post the link to it here

brice rebsamen gravatar image brice rebsamen  ( 2013-06-11 09:43:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2013-06-09 13:21:28 -0500

Jiayi Liu gravatar image

I am using fuerte on 12.04, and had the same problem. Here's my workaround and now I can rosmake my packages again! Since the error occurred at the perception_pcl stack, I overlaid it and recompiled the stack with the patch in my own workspace, thanks to this post

answers.ros.org/question/49447/error-with-pcl_ros-in-ros-fuerte/.

During the recompilation of the stack, it also bit me with another couple of errors, e.g., I had to softlink the GL header folder, and rebuild VTK with the -fPIC option (because I manually installed VTK previously with all default options).

Here are the steps, which are just a workaround and I hope a real solution is coming with a good ROS update.

  1. Copy the perception_pcl stack from /opt/ros/ to your workspace, and cd into it.
  2. rosws set pcl.
  3. rosws update pcl. (After this, resource your setup.bash file, and check if the new stack is in your $ROS_PACKAGE_PATH)
  4. Install the patch:

    code.ros.org/trac/ros-pkg/attachment/ticket/5243/perception_pcl-1.0.1-vtk5.8.patch.

  5. Delete all build folders (found two in pcl/ and pcl/msg/, respectively).

  6. rosmake pcl (Don't forget to delete the ROS_NOBUILD dummy beforehand) (Here I was given a compiling error related to VTK. If you luckily don't have it, go straight to Step 9.)
  7. Re-do your VTK.
    1. cd into your VTK source folder.
    2. mkdir build and cd into it.
    3. cmake .. gave me a missing file error as "file STRINGS file "/usr/local/include/GL/glx.h" cannot be read".
    4. sudo ln -s /usr/include/GL /usr/local/include
    5. ccmake . to configure your VTK
    6. make CFLAGS=-fPIC
    7. sudo make install
  8. rosmake pcl.
  9. rosmake your_package.
  10. YEH!
edit flag offensive delete link more

Comments

@Jiayi Liu.it did not work for me. i have installed ROS-fuerte by using apt-get. Steps I have followed are.I have confusion at 4th step and 5th step.I am new to Ubuntu and ROS might b i am doing mistakes. The output of 4th step is "patching file manifest.xml Hunk #1 FAILED at 31. 1 out of 1 hunk FA"

Muhammad Atif gravatar image Muhammad Atif  ( 2013-06-09 22:01:08 -0500 )edit

Hey @Muhammad Atif. By saying "install", I mean making changes to corresponding files, according to https://code.ros.org/trac/ros-pkg/attachment/ticket/5243/perception_pcl-1.0.1-vtk5.8.patch (the diffs). Btw, how did you get that output?

Jiayi Liu gravatar image Jiayi Liu  ( 2013-06-10 17:43:04 -0500 )edit

@Jiayi Liu.Now I have done the same just change the files.One thing i want to tell you i installed ROS by "apt-get".I have copied the perception_pcl package from /opt/ros/fuerte/stacks to /home/atif/fuerte_workspace. i have my package is /home/atif/fuerte_workspace/sandbox I am doing rite ?

Muhammad Atif gravatar image Muhammad Atif  ( 2013-06-10 19:57:30 -0500 )edit

Hi Jiayi, when i modified "cmake -P ${prefix}/vtk_include.cmake" lflags="-Lcmake -P ${prefix}/vtk_library.cmake" to "cat ${prefix}/vtk_include_dirs.txt" lflags="-Lcat ${prefix}/vtk_library_dirs.txt", this is what I got (next comment!)

VicL gravatar image VicL  ( 2013-06-11 03:29:06 -0500 )edit

"cat: /opt/ros/fuerte/stacks/perception_pcl/pcl/vtk_include_dirs.txt: No such file or directory".

rosmake pcl didnt show any errors.

Should I have deleted the perception_pcl stack at /opt/ros/fuerte/stacks?

Bythe way, what do you mean by redo VTK? Where shld the source file be at?

VicL gravatar image VicL  ( 2013-06-11 03:29:23 -0500 )edit

my package is in ~/fuerte_workspace/ btw!

VicL gravatar image VicL  ( 2013-06-11 03:34:04 -0500 )edit

The above answer worked when I installed a fresh copy of ubuntu 12.04 and fuerte and solved the issue

sai gravatar image sai  ( 2013-06-11 17:27:15 -0500 )edit

Thank you. It work.

Alexandr Buyval gravatar image Alexandr Buyval  ( 2013-06-11 21:25:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

6 followers

Stats

Asked: 2013-06-07 00:04:20 -0500

Seen: 1,135 times

Last updated: Jun 09 '13