Ask Your Question
1

TurtleBot Calibration File and Access

asked 2013-06-05 17:12:18 -0500

RobertT gravatar image

updated 2013-06-05 17:15:49 -0500

I want to forewarn that I am very new to using the TurtleBot and in general, the linux operating system. I am using Ubuntu 10.10 and running electric.

I have been able to sucuessfully run the calibration process but I immediately become stuck while trying to update old calibration data in order to create a new accurate calibration. I suppose because I am so inexperienced with the TurtleBot, linux and so forth that I am missing something here.

I want to save the new calibration data, but I can't find the correct file to save it on. The ROS tutorial seems overly vague and the command line that it gives

: sudo emacs -nw turtlebot.launch

Does not work. Is this because of my current verison of software?

Essentially, I don't want to update anything on either ubuntu or ROS. I just can't seem to access the correct file path and would appreciate some general tips and direction on this calibration process.

Thanks

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2013-06-12 11:03:02 -0500

Zayin gravatar image

updated 2013-06-12 11:04:10 -0500

You can indeed use dynamic reconfigure as a temporary fix, but you would need to do it every time. I also found the tutorial very vague, but I think I found another way to make it work. Find 'turtlebot_bringup minimal.launch' and add (these are my values):

<param name="turtlebot_node/gyro_scale_correction" value="1.4074"/>
<param name="turtlebot_node/odom_angular_scale_correction" value="1.0311"/>
<param name="turtlebot_node/gyro_measurement_range" value="250.0"/>

Obviously, you then need to start your Turtlebot with minimal.launch. You might need to use "gksudo gedit /pathToMinimalLaunch" to edit the file.

edit flag offensive delete link more
0

answered 2013-06-12 13:01:11 -0500

RobertT gravatar image

Ok, so after just searching around on the TurtleBot netbook, I think I have found the file. I am assuming this will work for any of you. For me, the sequence goes as this:

Go to places on the home screen : Places >> Computer >> file system >> etc >> ros >> electric >> turtlebot.launch

If you are using something other than electric, then obviously click on that. In the TurtleBot.launch file, you will see the permanent parameter settings that you can now changed.

Therefore, I fixed my own problem.

edit flag offensive delete link more

Comments

etc/ros/fuerte doesn't exist on my installation. It might be an electric-only thing.

Zayin gravatar image Zayin  ( 2013-06-13 04:45:15 -0500 )edit
0

answered 2013-06-12 08:01:28 -0500

shiloh gravatar image

updated 2013-06-12 08:02:07 -0500

I'm having the same problem, but I'm running Groovy. As a temporary fix, you could try changing the parameters using dynamic_reconfigure:

rosrun dynamic_reconfigure reconfigure_gui

In Groovy, this was succeeded by rqt_reconfigure:

rosrun rqt_reconfigure rqt_reconfigure

I hope this helps!

Documentation is here:

ros.org/wiki/dynamic_reconfigure

ros.org/wiki/rqt_reconfigure

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-06-05 17:12:18 -0500

Seen: 353 times

Last updated: Jun 12 '13