Ask Your Question
0

Turtlebot 2 on Virtual Machine with no Kinect picture

asked 2013-05-24 05:17:38 -0500

BlitherPants gravatar image

updated 2016-10-24 08:59:46 -0500

ngrennan gravatar image

Hello,

I am using a TurtleBot 2 with a Kobuki base. I can bring up the Kobuki dashboard and all the lights are green, but I get a constant "no devices connected" log message. It appears my Kinect is not properly working with the software (the light on the cable is not lit, though the light on the Kinect itself is)

Apparently this is a known issue that can be fixed by changing to "full mode" in the TurtleBot Dashboard, but I've looked all over the place and I can't figure out how to do this for the Kobuki version of the dashboard. Can anyone please tell me how to do this?

This is my first post here and I'm very new to everything about Linux, ROS, and the TurtleBot in general, so I sincerely apologize if this question is poorly worded or irrelevant.

Thanks in advance.

------------------EDIT------------ Adding the steps I've taken, but needed to remove anything that looked like a link because I don't have enough karma to post those...

First thing I do is connect the power to the Kinect (light on the cable goes green), and connect the Kinect USB and the Kobuki USB to the laptop. Then, I run roslaunch turtlebot_bringup minimal.launch and get the following:

SUMMARY
========

PARAMETERS
 * /app_manager/interface_master
 * /bumper2pointcloud/pointcloud_radius
 * /cmd_vel_mux/yaml_cfg_file
 * /diagnostic_aggregator/analyzers/input_ports/contains
 * /diagnostic_aggregator/analyzers/input_ports/path
 * /diagnostic_aggregator/analyzers/input_ports/remove_prefix
 * /diagnostic_aggregator/analyzers/input_ports/timeout
 * /diagnostic_aggregator/analyzers/input_ports/type
 * /diagnostic_aggregator/analyzers/kobuki/contains
 * /diagnostic_aggregator/analyzers/kobuki/path
 * /diagnostic_aggregator/analyzers/kobuki/remove_prefix
 * /diagnostic_aggregator/analyzers/kobuki/timeout
 * /diagnostic_aggregator/analyzers/kobuki/type
 * /diagnostic_aggregator/analyzers/power/contains
 * /diagnostic_aggregator/analyzers/power/path
 * /diagnostic_aggregator/analyzers/power/remove_prefix
 * /diagnostic_aggregator/analyzers/power/timeout
 * /diagnostic_aggregator/analyzers/power/type
 * /diagnostic_aggregator/analyzers/sensors/contains
 * /diagnostic_aggregator/analyzers/sensors/path
 * /diagnostic_aggregator/analyzers/sensors/remove_prefix
 * /diagnostic_aggregator/analyzers/sensors/timeout
 * /diagnostic_aggregator/analyzers/sensors/type
 * /diagnostic_aggregator/base_path
 * /diagnostic_aggregator/pub_rate
 * /mobile_base/base_frame
 * /mobile_base/battery_capacity
 * /mobile_base/battery_dangerous
 * /mobile_base/battery_low
 * /mobile_base/cmd_vel_timeout
 * /mobile_base/device_port
 * /mobile_base/odom_frame
 * /mobile_base/publish_tf
 * /mobile_base/wheel_left_joint_name
 * /mobile_base/wheel_right_joint_name
 * /robot/name
 * /robot/type
 * /robot_description
 * /robot_pose_ekf/freq
 * /robot_pose_ekf/imu_used
 * /robot_pose_ekf/odom_used
 * /robot_pose_ekf/output_frame
 * /robot_pose_ekf/sensor_timeout
 * /robot_pose_ekf/vo_used
 * /robot_state_publisher/publish_frequency
 * /rosdistro
 * /rosversion
 * /turtlebot_laptop_battery/acpi_path
 * /use_sim_time
 * /zeroconf/zeroconf_avahi/services

NODES
  /zeroconf/
    zeroconf_avahi (zeroconf_avahi/zeroconf)
  /
    app_manager (turtlebot_app_manager/app_manager)
    appmaster (turtlebot_app_manager/appmaster)
    bumper2pointcloud (nodelet/nodelet)
    cmd_vel_mux (nodelet/nodelet)
    diagnostic_aggregator (diagnostic_aggregator/aggregator_node)
    mobile_base (nodelet/nodelet)
    mobile_base_nodelet_manager (nodelet/nodelet)
    robot_pose_ekf (robot_pose_ekf/robot_pose_ekf)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)
    turtlebot_laptop_battery (linux_hardware/laptop_battery.py)

auto-starting new master
process[master]: started with pid [2069]
ROS_MASTER_URI=*removed because I can't post links*
setting /run_id to 31b356b6-c889-11e2-a601-0800271ddb21
process[rosout-1]: started with pid [2082]
started core service [/rosout]
process[zeroconf/zeroconf_avahi-2]: started with pid [2085]
process[robot_state_publisher-3]: started with pid [2086]
process[diagnostic_aggregator-4]: started with pid [2107]
process[mobile_base_nodelet_manager-5]: started with pid [2119]
process[mobile_base-6]: started with pid [2120]
process[robot_pose_ekf-7]: started with pid [2121]
process[cmd_vel_mux-8]: started with pid [2140]
process[bumper2pointcloud-9]: started with pid [2141]
process[turtlebot_laptop_battery-10]: started with pid [2260]
process[appmaster-11]: started with pid [2409]
process[app_manager-12]: started with pid [2496]

After this, the Kobuki plays a little tune. Then, I ... (more)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-05-26 15:49:38 -0500

bit-pirate gravatar image

Hi Pants,

I'm not aware of any 'full mode' for Kobuki - maybe that belongs to the Create? If you talk about the launch files, then there is a minimal.launch, which only brings up the minimal configuration needed for the TurtleBot to run (e.g. does not include the driver for the Kinect). On top you are supposed to start whatever you need to run your application, e.g. navigation. Please add to your question what programs/nodes/launchers you are starting/using to reproduce your problem.

Looking at your problem that the Kinect is not working, I noticed you have mentioned that the LED on the Kinect cable is not lit. That's odd. It is supposed to be turned on. Please check, that the connection cable is plugged into the netbook (data) and the Kobuki base (power).

edit flag offensive delete link more

Comments

Hi bit-pirate, thanks for the response! The reason I expected full mode to solve the problem is this line in the user manual for Turtlebot 2: "Kinect is not responding and green light on Kinect adaptor is off. Either issue a motion command to the Create or use the SetTurtlebotMode service in

BlitherPants gravatar imageBlitherPants ( 2013-05-27 04:16:51 -0500 )edit

continued turtlebot_node to change the mode to "full mode" . "

Anyway, these are the steps I've taken: 1. Put desktop and laptop on same network (via Hamachi VPN) 2. Plug laptop to Kobuki via USB cable 3. Plug Kinect power to 12V 1.5A port on Kobuki, and Kinect USB to laptop 4 Turn Kobuki on

BlitherPants gravatar imageBlitherPants ( 2013-05-27 04:27:04 -0500 )edit
  1. On laptop, run "roslaunch turtlebot_bringup minimal.launch" and wait for the Kobuki to play a happy sound
  2. On desktop, run "rqt -s kobuki_dashboard" -- all the lights on the top left of the window are green
BlitherPants gravatar imageBlitherPants ( 2013-05-27 04:43:14 -0500 )edit
  1. Open a new terminal on the laptop and run "roslaunch turtlebot_bringup 3dsensor.launch. After this step, the dashboard on the workstation starts displaying "no devices connected" messages.
  2. Open new workstation terminal and run "roslaunch turtlebot_rviz_launchers view_robot.launch"
BlitherPants gravatar imageBlitherPants ( 2013-05-27 04:46:29 -0500 )edit

The window that opens shows no Kinect output and I'm not surprised, since the cable light is still not lit even though the Kinect light is. Is there another roslaunch command that is needed to start up the Kinect? Trying to follow the tutorial (http://ros.org/wiki/turtlebot) exactly

BlitherPants gravatar imageBlitherPants ( 2013-05-27 04:48:49 -0500 )edit

BTW, running ROS Groovy and Ubuntu 12.04 (64 bit) on a VirtualBox on both computers. I can run the keyboard teleop demo perfectly fine. Sorry for the comment spam. A little confused by the character limit and not sure if I'm doing something wrong here...

BlitherPants gravatar imageBlitherPants ( 2013-05-27 04:51:08 -0500 )edit

I have found the advice you mentioned in Clearpath's TurtleBot 2 manual. Is this the one you are referring to? Since they mention the Create, which is used in the TurtleBot 1, I'm assuming they just missed to update it. For Kobuki - used in TurtleBot 2 - there is no such thing as a "full mode".

bit-pirate gravatar imagebit-pirate ( 2013-05-27 20:39:02 -0500 )edit

Now looking at your Kinect problem: 1. Try to avoid using virtual machines. I tried it once and failed with getting the Kinect running. Others noticed similar problems. Not sure, if there is a working solution other there to get the Kinect running inside a virtual machine.

bit-pirate gravatar imagebit-pirate ( 2013-05-27 20:41:54 -0500 )edit
0

answered 2013-06-10 08:18:31 -0500

BlitherPants gravatar image

Hi,

In case anyone is still interested in this question, I gave up using VirtualBox entirely. I ended up buying this laptop: www.woot.com/offers/asus-11-6-touchscreen-core-i3-vivobook

I set up a dual-boot of Ubuntu 12.04 alongside Windows and suddenly the rviz and follower tutorials work fine. In the future I'd love to use some port monitor to see why the Kinect wasn't showing properly.

Thanks to bit-pirate for contributing.

edit flag offensive delete link more

Comments

I'm glad you found a solution to your problem. Please close this question by selecting the answer which you like most (click the checker sign on the top left of the answer). Thanks!

bit-pirate gravatar imagebit-pirate ( 2013-06-10 23:45:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-24 05:17:38 -0500

Seen: 1,454 times

Last updated: Jun 10 '13