Ask Your Question
0

Issue with MoveIt Tutorials

asked 2013-05-22 06:35:07 -0500

BenjaminV gravatar image

updated 2013-11-14 10:52:48 -0500

tfoote gravatar image

Hello,

I try to launch the tutorials from MoveIt, but it's not working, I get this error message :

ERROR: cannot launch node of type [pr2_moveit_tutorials/kinematic_model_tutorial]: can't locate node [kinematic_model_tutorial] in package [pr2_moveit_tutorials]

I have installed ROS and moveit with instructions from

  • [ROS] www.ros.org/wiki/groovy/Installation/Ubuntu
  • [MoveIt] moveit.ros.org/wiki/index.php/Groovy/Installation

not from sources.

I tried to install from sources but I had another issue : RViz refused to launch, it throw me this error :

rviz: /build/buildd/ogre-1.7.4/OgreMain/src/OgreSceneManager.cpp :807 : virtual Ogre::SceneNode* Ogre::SceneManager::createSceneNode(): the assertion « mSceneNodes.find(sn->getName()) == mSceneNodes.end() » has failed.

Can anybody help me?

THanks!

Ben

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2013-05-22 09:04:41 -0500

isucan gravatar image

Sorry about this, this is an error in our installation process for the tutorials package. It will be corrected in the next release. In the meantime, you can get the package from source and run the launch files from there.

edit flag offensive delete link more

Comments

Ok for the package version but still, I have already tried from sources, and it's not working (see the Ogre error)

BenjaminV gravatar image BenjaminV  ( 2013-05-23 02:50:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-22 06:35:07 -0500

Seen: 330 times

Last updated: May 22 '13