Ask Your Question
0

Hokuyo UTM-30LX-EW not detected in Ubuntu or PC

asked 2013-05-15 10:04:35 -0500

redarean gravatar image

updated 2014-01-28 17:16:32 -0500

ngrennan gravatar image

Hi,

I am a newbie user for ROS. I am trying to run the Hokuyo UTM-30LX-EW LiDAR (with ethernet connection) using urg_node on Ubuntu 12.04 with ROS-Groovy.

When I run the following commands (in separate terminal windows)

roscore
rosrun urg_node urg_node _ip_address:="192.168.0.10"

I get the following error:

[FATAL] [1368644464.256278611]: Could not open network Hokuyo:
192.168.0.10:10940
could not open ethernet port.

Sadly, I also cannot get the tools issued by the manufacturer to detect the LiDAR when I try to connect in a Windows environment.

For both these situations, the laser scanner is switched on and connected when this happens. Also, the LEDs are lit steady after blinking for a few seconds on connection.

Can someone please provide me suggestions about what might be going on? Our lab spent a lot of money buying this equipment and I would like that to be put to good use!

Thanks in advance :-)

edit retag flag offensive close merge delete

Comments

You are correct, the urg_node will not work if there is no connectivity to the laser. Setting the IP address of the computer to match that of the laser should resolve your problem.

mjcarroll gravatar image mjcarroll  ( 2013-05-20 10:15:02 -0500 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2013-05-15 13:07:13 -0500

redarean gravatar image

Hi,

I heard back from the manufacturer's technical support just now and his troubleshooting tip resolved the problem. Apparently, it was an IP mismatch with my corporate network computer all along! I am pasting his reply below so that others may benefit from this.

Moderators, please close this question (I do not have sufficient reputation to do so)

Thanks!


From: Sup PREMVUTI (Kirinson, Inc.) [] Sent: Wednesday, May 15, 2013 3:49 PM Subject: RE: Cannot connect to the Hokuyo UTM-30LX-EW

Hi,

Please try the following steps.

(1) Use a Windows PC or Laptop and use its Ethernet port directly. (2) Set the property of your Ethernet port TCP/IP4 to the following. (Do not select ‘Obtain an IP address automatically’)

   IP Address 192.168.0.15
   Subnet Mask 255.255.255.0
   Default Gateway 192.168.0.1

The laser scanner and the PC have to be on the same net, e.g. 192.168.0.XX. For this step, we put the PC on 192.168.0.15. The default IP address of the laser scanner is 192.168.0.10 and port number is 10940.

(3) Connect the laser scanner to the Ethernet port of the PC.

(4) Run URG Benri.

Let me know if this helps.

Thanks,

Sup


edit flag offensive delete link more
0

answered 2014-02-04 22:45:59 -0500

marilia15 gravatar image

I have the same problem but I can not solve it with your instructions.

I have a new Hokuyo UTM-30LX-EW, my machine is ubuntu 13.04 with ROS groovy.

I configure the network with: sudo ifconfig eth0 192.168.0.15 masc 255.255.255.0 route add default gw 192.168.0.1

Then, I connect the hokuyo in the ethernet port, and I capture packages with:

sudo wireshark > start capture in eth0 interface. or tcpdump -i eth0 port 10940

But any package from outside my IP is captured. Am I missing something???

Thanks in advance.

edit flag offensive delete link more

Comments

Have you tried this: http://sourceforge.net/p/urgnetwork/wiki/UTM-30-EW%20on%20ROS/ ? It worked pretty well for me :-)

redarean gravatar image redarean  ( 2014-02-05 04:51:06 -0500 )edit
0

answered 2013-05-18 14:49:52 -0500

Sentinal_Bias gravatar image

Hi i have used this LIDAR before with ROS

Hokuyo UTM-30LX-EW is an Ethernet (SCIP2.2) multiecho based LIDAR and is not supported by the current ROS hokuyo node, but will be supported in the hydro distribution I heard.

I used the IRI ros drivers to connect to this LIDAR

I used this http://wiki.iri.upc.edu/index.php/Hokuyo_Laser_driver

edit flag offensive delete link more

Comments

The urg_node is available for Groovy and Hydro here: https://github.com/ros-drivers/urg_node It wraps the Hokuyo supplied library for their lasers, and should support both serial and ethernet lasers. it is also compliant with the new REP 138 (Multiecho lasers).

mjcarroll gravatar image mjcarroll  ( 2013-05-20 10:16:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-05-15 10:04:35 -0500

Seen: 9,401 times

Last updated: Feb 04 '14