ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

utm-30lx cannot ping 192.168.0.10

asked 2021-11-10 23:23:16 -0500

Nur92 gravatar image

updated 2021-11-11 18:31:52 -0500

miura gravatar image

Hello. I have problem to ping with default IP address of the hokuyo utm-30lx. I'm using ubuntu 20.04. Is there anyone know how to solve this problem? Thank you

edit retag flag offensive close merge delete

Comments

Take a look at this prior answer: https://answers.ros.org/question/2125...

osilva gravatar image osilva  ( 2021-11-11 07:20:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-11-11 17:42:40 -0500

miura gravatar image

updated 2021-11-11 17:43:23 -0500

This is probably because the source IP of the ping is not 192.168.0.XXX, and you need to belong to the same network in order to ping each other.

Try changing the IP address of the ping source to 192.168.0.XXX.

edit flag offensive delete link more

Comments

I already change the IP address of the ping source to 192.168.0.XXX and when to use rosrun urg_node urg_node _ip_address:=192.168.0.XXX it show [Error connecting to Hokuyo: Could not open network Hokuyo: 192.168.0.XXX:10940 could not open ethernet port]

Nur92 gravatar image Nur92  ( 2021-11-11 19:10:25 -0500 )edit

XXX in urg_node _ip_address:=192.168.0.XXX is the part that specifies the IP address of the utm-30lx. if you have not tried urg_node _ip_address:=192.168.0.10, try it.

If it still does not work, the IP address of utm-30lx may be wrong.

miura gravatar image miura  ( 2021-11-12 19:51:44 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2021-11-10 23:23:16 -0500

Seen: 67 times

Last updated: Nov 11 '21