Ask Your Question
0

RGBDSLAM_freiburg : 'node not found' on groovy

asked 2013-05-08 09:15:19 -0600

Maheshwar Venkat gravatar image

updated 2014-01-28 17:16:28 -0600

ngrennan gravatar image

I installed and built rgbdslam_freiburg as given in http://www.ros.org/wiki/rgbdslam. When I tried to execute the following command

roslaunch rgbdslam kinect+rgbdslam.launch

I got the following error:

ERROR: cannot launch node of type [rgbdslam/rgbdslam]: can't locate node [rgbdslam] in package [rgbdslam]

'roscd' is able to locate the package rgbdslam. It is found inside my catkin workspace, where I downloaded the code from this link http://alufr-ros-pkg.googlecode.com/svn/trunk/rgbdslam_freiburg given in the tutorial

However rosnode info rgbdslam returns cannot contact [/rgbdslam]: unknown node

I'm running ros groovy on Ubuntu 12.10

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-14 04:50:57 -0600

Have you compiled it? It's not a binary download. See the wiki page for how to do it.

edit flag offensive delete link more

Comments

compiled it. but still it shows same error..

leo pauly gravatar imageleo pauly ( 2014-01-20 06:18:00 -0600 )edit

And compilation was successful, I assume. You have to find the binary then. Try searching in your workspace with "find -executable -name rgbdslam -type f".

Felix Endres gravatar imageFelix Endres ( 2014-01-23 22:46:15 -0600 )edit

I have the same problem. Compilation was succesful. Any update on this? Also, I noticed that I can't use rosrun or roscd, altough I included "source /opt/ros/hydro/setup.bash" in my ~/.bashrc file. The other ros-commands are working.

Michiel gravatar imageMichiel ( 2014-01-29 03:21:24 -0600 )edit

I have migrated rgbdslam to hydro. Let me know whether you would like to test a probably unstable release.

Felix Endres gravatar imageFelix Endres ( 2014-02-14 01:15:50 -0600 )edit

im running on ros hydro.but still the error continues

leo pauly gravatar imageleo pauly ( 2014-02-22 22:55:20 -0600 )edit

Leo: Please be specific. You are running what on ros hydro? The rgbdslam package from googlecode?

Felix Endres gravatar imageFelix Endres ( 2014-02-25 21:28:12 -0600 )edit

Michiel:Have you created a workspace and sourced the respective setup.bash, so that rgbdslam is in your package path? Check with "echo $ROS_PACKAGE_PATH"

Felix Endres gravatar imageFelix Endres ( 2014-02-25 21:29:15 -0600 )edit

@leo pauly@Michiel@Felix Endres Do you use catkin workspace or rosbuild one? The instruction uses a rosbuild ws. I am not sure which is correct to install this package on hydro.

pinocchio gravatar imagepinocchio ( 2014-03-26 15:19:33 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-08 09:15:19 -0600

Seen: 884 times

Last updated: May 14 '13