ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

RGBDSLAM_freiburg : 'node not found' on groovy

asked 2013-05-08 09:15:19 -0500

Maheshwar Venkat gravatar image

updated 2014-01-28 17:16:28 -0500

ngrennan gravatar image

I installed and built rgbdslam_freiburg as given in When I tried to execute the following command

roslaunch rgbdslam kinect+rgbdslam.launch

I got the following error:

ERROR: cannot launch node of type [rgbdslam/rgbdslam]: can't locate node [rgbdslam] in package [rgbdslam]

'roscd' is able to locate the package rgbdslam. It is found inside my catkin workspace, where I downloaded the code from this link given in the tutorial

However rosnode info rgbdslam returns cannot contact [/rgbdslam]: unknown node

I'm running ros groovy on Ubuntu 12.10

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-05-14 04:50:57 -0500

Have you compiled it? It's not a binary download. See the wiki page for how to do it.

edit flag offensive delete link more


compiled it. but still it shows same error..

leo pauly gravatar image leo pauly  ( 2014-01-20 06:18:00 -0500 )edit

And compilation was successful, I assume. You have to find the binary then. Try searching in your workspace with "find -executable -name rgbdslam -type f".

Felix Endres gravatar image Felix Endres  ( 2014-01-23 22:46:15 -0500 )edit

I have the same problem. Compilation was succesful. Any update on this? Also, I noticed that I can't use rosrun or roscd, altough I included "source /opt/ros/hydro/setup.bash" in my ~/.bashrc file. The other ros-commands are working.

Michiel gravatar image Michiel  ( 2014-01-29 03:21:24 -0500 )edit

I have migrated rgbdslam to hydro. Let me know whether you would like to test a probably unstable release.

Felix Endres gravatar image Felix Endres  ( 2014-02-14 01:15:50 -0500 )edit

im running on ros hydro.but still the error continues

leo pauly gravatar image leo pauly  ( 2014-02-22 22:55:20 -0500 )edit

Leo: Please be specific. You are running what on ros hydro? The rgbdslam package from googlecode?

Felix Endres gravatar image Felix Endres  ( 2014-02-25 21:28:12 -0500 )edit

Michiel:Have you created a workspace and sourced the respective setup.bash, so that rgbdslam is in your package path? Check with "echo $ROS_PACKAGE_PATH"

Felix Endres gravatar image Felix Endres  ( 2014-02-25 21:29:15 -0500 )edit

@leo pauly@Michiel@Felix Endres Do you use catkin workspace or rosbuild one? The instruction uses a rosbuild ws. I am not sure which is correct to install this package on hydro.

pinocchio gravatar image pinocchio  ( 2014-03-26 15:19:33 -0500 )edit

Question Tools


Asked: 2013-05-08 09:15:19 -0500

Seen: 961 times

Last updated: May 14 '13