ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Problem of android_tutorial_camera

asked 2013-05-06 16:19:47 -0600

zieben gravatar image


I have problem to run android_tutorial_camera ( First of all, what is the meaning of "Make sure that your Android device is connected to the same network as your Linux machine (e.g., on the same wifi network)" on the ros core wiki? Does it mean that both of Linux machine and Android device should have same gateway like Linux machine: / Android device:

Anyway, For now, my configuration is like this. Linux PC is using a wired network(125...) and Android tablet is connected to wireless network(153...) The problem is that I cannot see the camera image of android device on Linux PC ROS is running. I have tried to find solution in ROSanswers and did something as follows:

  • Checking network connection between Linux PC and android tablet through ping command.
  • $export ROS_IP = XXX.XXX.XXX.XXX (Linux computer IP)
  • $export ROS_HOSTNAME = XXX.XXX.XXX.XXX (Same as ROS_IP)

However there is no changes. I tried this example on galaxy tab 7inch (Android v2.2.3) and galaxy nexus(v4.2)

This is message when I run roscore, (XXX.XXX.XXX.XXX is same as linux computer IP)

$ roscore . . .

auto-starting new master process[master]: started with pid [22361] ROS_MASTER_URI=http://XXX.XXX.XXX.XXX:11311/

setting /run_id to *********** process[rosout-1]: started with pid [22374] started core service [/rosout]

When I check the rostopic, it is same as follows:

$ rostopic list /camera/camera_info /camera/image/compressed /rosout /rosout_agg

What can I do more? Thank you.

edit retag flag offensive close merge delete


Hi, What is rxgraph outputting? Is Node on Android connected with nodes on PC?

Alexandr Buyval gravatar image Alexandr Buyval  ( 2013-05-06 20:19:49 -0600 )edit

Thank you for your comment. I can see the message in Info of rxgraph like this: ERROR: Communication with node[http://XXX.XXX.XXX.XXX:39112/] failed!

zieben gravatar image zieben  ( 2013-05-07 14:44:53 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-05-08 07:21:16 -0600

zieben gravatar image

updated 2013-05-09 11:19:06 -0600

Thank you for your comment.

I found one solution. If I use linux machine and android device on the same local network (e.g. linux machine:, android device:, this tutorial is working perfectly. However it still isn't working when I use both pn different network.

So I want to change my question. How I set my linux PC network setting? For now, e.g.

Linux PC physical IP:

  • ROS_IP =


  • ROS_MASTER_URI = http://localhost:11311/

Android device physical IP: and I entered on the camera_tutorial_app as master URI

Is that right? thank you.

edit flag offensive delete link more

answered 2013-05-07 20:50:21 -0600

damonkohler gravatar image

Check adb logcat and make sure that your Android device is able to connect to the master and that the publisher is successful registered. It's likely that this is purely a networking issue.

Log the address used in your NodeConfiguration and check that it is accessible by the Linux PC.

You may also try downloading a ping app for Android and use it to verify connectivity in that direction.

edit flag offensive delete link more

Question Tools


Asked: 2013-05-06 16:19:47 -0600

Seen: 1,346 times

Last updated: May 09 '13