Ask Your Question
1

rosjava over bluetooth: Android to PC (Ubuntu)

asked 2014-11-17 18:01:55 -0600

chris_amelinckx gravatar image

Hi,

I am building an android app to monitor our robots. The main ros nodes run on an Ubuntu PC station.

Currently my android rosjava node can talk to the ros nodes on the PC station using wifi.

What I need next is to connect the Android node and the ros PC station using Bluetooth.

Do you have any pointers for achieving this?

Thanks!

edit retag flag offensive close merge delete

Comments

I think now ROS is just working with ethernet TCP/IP, it doesnt not supported for bluetooth (just my opinion)

domikilo gravatar imagedomikilo ( 2014-11-17 23:22:04 -0600 )edit

If that's the case, maybe something like ROS-Serial could help?

Rabe gravatar imageRabe ( 2014-11-18 01:52:26 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
4

answered 2014-11-19 17:07:05 -0600

chris_amelinckx gravatar image

updated 2015-01-08 08:09:44 -0600

I have achieved the goal of connecting an android rosjava node to a roscore running on Ubuntu via bluetooth, by:

Creating an ad-hoc bluetooth network; for this I installed the "Blueman Bluetooth Manager" following the instructions on the linked askubuntu question

To be clear, even though this would achieve it, I am not sharing the internet connection of my ubuntu machine with the android tablet, since in my scenario this experiment will run in remote areas, so I actually have the wifi turned off on both the ubuntu machine and the android tablet.

I paired a Nexus 7 Android to an aspire ubuntu netbook (which has an ioGear BT 4.0 USB mini dongle model GBU521W6)

Another detail is that in the Nexus 7, when pairing the devices you need to click on the settings and select the "Internet Access" bluetooth profile, by default it will connect only to the Media audio profile (I disabled that one also).


2014-1121 Additional Update for Ubuntu 14.04 The above instructions had worked flawlessly on Ubuntu 13.04

On 14.04 Trusty the current Blueman Bluetooth Manager has an issue in that the system status bar icon does not show up and therefore doesn't allow you to get to the Local Services dialog.

This is easily resolved by launching them from a terminal window by doing either: blueman-services

(this should have been installed on your local /usr/bin)

(you can also launch the blueman manager by running blueman-manager)

edit flag offensive delete link more

Comments

Hi there, When you pair the devices and make sure the Internet Access profile is enabled on Android, do you just connect to the PC as usual by inputting the ROS_MASTER_URI in the android app? When I do this, the android topics still don't appear when using rostopic list in the PC.

hiro64 gravatar imagehiro64 ( 2014-12-01 05:46:51 -0600 )edit

Yes, however check that: 1. Your local ROS_IP environment setting is set to the IP address of the ad-hoc bluetooth network. (blueman generates a random one for you, you can override it also) 2. On your android app, you would connect using http://{THAT_SAME_IP}:11311 (or whichever port number used)

chris_amelinckx gravatar imagechris_amelinckx ( 2014-12-01 15:29:55 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2014-11-17 18:01:55 -0600

Seen: 2,052 times

Last updated: Jan 08 '15