Ask Your Question
2

Supported Android API levels in rosjava

asked 2011-06-04 14:46:06 -0500

Hordur gravatar image

Has there been any decision made on what API levels will be supported in rosjava? The reason I ask is that I noticed the Android libraries and tutorials set minSdkVersion to 9.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2011-06-05 07:32:39 -0500

kwc gravatar image

It should work on Android Level 8. The Level 9 is due to the fact that the original implementation used a class that required level 9. This has since been fixed.

edit flag offensive delete link more

Comments

The OrientationPublisher in the Android library is using TYPE_ROTATION_VECTOR which is level 9.
Hordur gravatar imageHordur ( 2011-06-05 16:13:09 -0500 )edit
We'll have to figure out some other ways to package those sensor examples as those are constantly evolving with the API levels -- you can use the actual communication parts w/o level 9.
kwc gravatar imagekwc ( 2011-06-06 04:16:00 -0500 )edit
0

answered 2013-02-25 01:21:54 -0500

dberm22 gravatar image

I know this is an old question, but this is for future viewers who have the same question. I have used it on 2.3 without a problem, and I am currently using it on 4.2 with no issues. I was nervous whether or not it would work on 4.2 when I told my company to purchase a tablet for me. Luckily it did.

edit flag offensive delete link more
0

answered 2011-06-06 04:11:06 -0500

damonkohler gravatar image

In the near future the required API level should be closer to Donut. The base library will have very few dependencies on Android APIs.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-04 14:46:06 -0500

Seen: 367 times

Last updated: Feb 25 '13