Ask Your Question
3

ROS on Android Tutorials

asked 2011-07-19 18:46:37 -0500

Micke gravatar image

Hi,

Im new to ROS and Android Programming and Java but I really would like to try out ROS on my Samsung Nexus-S.

I have been searching for information/tutorials on how to get it running, I have even intimidated googles with questions on Google+ to try to figure out what Im doing wrong,.

So I figured I would write down what I've done, and maybe someone can point out where I went wrong.

  • First. Im running Linux Ubuntu 11.04 on a VMWare fusion 3.1.3 on my MAC OSX 10.6.8.

  • I downloaded ros diamond back (the natty one) from ros.org and followed the installation guide at: http://www.ros.org/wiki/diamondback/I... . No problem here except that apt-get didn't find any configuration called: "ros-diamondback-desktop-full" so I used "ros-diamondback-desktop"

  • I ran through a few of the tutorials did some rosmake, roscd, rosls, rosrun etc.. worked fine.

  • The downloaded Eclipse from here http://www.eclipse.org/downloads/ (I took the one for C++ and Linux) and tried to debug an step through the C++ tutorials from ROS. THat worked fine to.

  • I then downloaded Android SDK from here: http://developer.android.com/sdk/inst... . and the ADT plugin for eclipse.

  • I followed the Hello World tutorial, just to make sure I was http://developer.android.com/resource... able to get an app running on my phone.

  • First my phone wouldn't show up in my Linux running in Fusion, to fix that I had to modify the vmware config file. (located in the MAC file directory where I store my Virtual Machines.) The file does't show up in the Finder, but in a Terminal I did:

    $ vi Ubuntu.vmwarevm/Ubuntu.vmx (my virtual machine is called Ubuntu)

In that file I added:

usb.quirks.device0 = "0x18d1:0x4e22 skip-reset"

At the end. I found the uid and vid by doing a:

$ tail -f Ubuntu.vmwavevm/wmare.log

and when inserting the phone the vid and uid showed up.

  • So now I can build/download/debug the Hello World Andriod App.

  • Next I created a folder ~/ros and added this to my ~/.bashrc in Linux:

source /opt/ros/diamondback/setup.bash export ROS_PACKAGE_PATH=~/ros:$ROS_PACKAGE_PATH export PATH=~/andriod/android-sdk-linux_x86/tools:$PATH

  • Then I Googled for ROS Android and found: http://www.ros.org/wiki/android . I followed the directions on that page, and Installed SL4A and PY4A on my phone, but as I understand it now, I dont need anything of that. Python is the OLD way of running ROS on Android. What we want to do is run Java! (Actually I didn't get enythinhg work according to the this wiki).

  • Instead I found http://www.ros.org/wiki/rosjava and the Overview.

  • I read a bit and thought I needed ant to build stuff so I did a

    $ sudo apt-get install ant.

(Actually I think I did that before the Android SDK installation, im not sure I needed to do that step ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2011-07-20 19:14:13 -0500

Micke gravatar image

Like a ROS and Android Virgin, I made it through the wilderness, some how I made it through,...

I now have the pubsub tutorial running on my Samsung,. thanks everyone

edit flag offensive delete link more

Comments

This whole thing is a little ridiculous. None of the tutorials will compile with indigo and Android Studio. Does ROS on Android really exist? I have over twenty years programming experience, and can not get any of the tutorials working and running on my android device.

elchan gravatar imageelchan ( 2015-03-04 15:43:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-19 18:46:37 -0500

Seen: 3,136 times

Last updated: Jul 20 '11