Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Problem of android_tutorial_camera

Hello,

I have problem to run android_tutorial_camera (http://www.ros.org/wiki/android_core) First of all, what is the meaning of "Make sure that your Android device is connected to the same network as your Linux machine (e.g., on the same wifi network)" on the ros core wiki? Does it mean that both of Linux machine and Android device should have same gateway like Linux machine: 100.0.0.1 / Android device: 100.0.0.2?

Anyway, For now, my configuration is like this. Linux PC is using a wired network(125...) and Android tablet is connected to wireless network(153...) The problem is that I cannot see the camera image of android device on Linux PC ROS is running. I have tried to find solution in ROSanswers and did something as follows:

  • Checking network connection between Linux PC and android tablet through ping command.
  • $export ROS_IP = XXX.XXX.XXX.XXX (Linux computer IP)
  • $export ROS_HOSTNAME = XXX.XXX.XXX.XXX (Same as ROS_IP)

However there is no changes. I tried this example on galaxy tab 7inch (Android v2.2.3) and galaxy nexus(v4.2)

This is message when I run roscore, (XXX.XXX.XXX.XXX is same as linux computer IP)

$ roscore . . .

auto-starting new master process[master]: started with pid [22361] ROS_MASTER_URI=http://XXX.XXX.XXX.XXX:11311/

setting /run_id to *********** process[rosout-1]: started with pid [22374] started core service [/rosout]

When I check the rostopic, it is same as follows:

$ rostopic list /camera/camera_info /camera/image/compressed /rosout /rosout_agg

What can I do more? Thank you.