Ask Your Question
1

Build android_tutorial_camera

asked 2012-09-28 04:26:04 -0500

Marcel gravatar image

updated 2012-09-30 22:33:36 -0500

I tried to connect my android phone with ROS according to the following tutorial:

Run a ROS Android example project http://www.ros.org/wiki/rosjava/Tutorials/Run%20a%20ROS%20Android%20example%20project

More precisely I tried to put the android_tutorial_camera to my phone, but I get at the tutorial http://docs.rosjava.googlecode.com/hg/android_core/html/building.html allways the error message that Execution failed for task ':android_acm_serial:updateProject'. A problem occurred starting command 'android'.

If I follow the tutorial I get lots of error in the android_gingerbread_mr1 witch is necassary for the android_tutorial_camera. Basically the errors happens because the import of com.google. ... can't be resolved by the compiler.

What can I do to fix this problem and the resolve this library?

I think it's the same problem from the following link: http://answers.ros.org/question/33511/build-failed-when-build-the-android_core-in-rosjava/ But although I followed the instruction there I wasn't able to compile the tutorials.

Thanks for helping

edit retag flag offensive close merge delete

Comments

Make sure you have a look at the support site. Please always copy-paste the exact error message.

Lorenz gravatar image Lorenz  ( 2012-09-28 05:50:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-10-01 02:17:54 -0500

Marcel gravatar image

updated 2013-03-17 20:36:14 -0500

130s gravatar image

I found the answer on the webpage http://www.dobots.nl/blog/-/blogs/android-and-rosjava

Adding the following lines to the ~/.bashrc file hepled:

export PATH=$PATH:/opt/android-sdk-linux_x86/tools
export CLASSPATH=$CLASSPATH:/opt/android-sdk-linux_x86/tools  # Depends on where you install Android Developer Tools
sudo killall java
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-09-28 04:26:04 -0500

Seen: 887 times

Last updated: Mar 17 '13