Ask Your Question
0

Any solution to roscore crash?

asked 2013-04-23 19:35:35 -0600

tgaaly gravatar image

updated 2013-04-24 07:13:55 -0600

ahendrix gravatar image

Hi, Im running ros fuerte and when I run roscore I get the following error. Has anyone found a solution to this. I tried updating ubuntu. It seems that there is no agreed upon solution for this problem. I would appreciate any help on this.

asctec@asctec-mastermind:~$ roscore
WARNING: unable to configure logging. No log files will be generated
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://asctec-mastermind:43141/
ros_comm version 1.8.11

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /rosversion

NODES

auto-starting new master
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[master]: started with pid [1984]
Traceback (most recent call last):
  File "/opt/ros/fuerte/bin/rosmaster", line 35, in <module>
    rosmaster.rosmaster_main()
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/ros_comm-1.8.7-py2.7.egg/rosmaster/main.py", line 73, in rosmaster_main
    configure_logging()   
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/ros_comm-1.8.7-py2.7.egg/rosmaster/main.py", line 57, in configure_logging
    _log_filename = rosgraph.roslogging.configure_logging('rosmaster', logging.DEBUG, filename=filename)
  File "/opt/ros/fuerte/lib/python2.7/dist-packages/ros_comm-1.8.7-py2.7.egg/rosgraph/roslogging.py", line 104, in configure_logging
    logging.config.fileConfig(config_file, disable_existing_loggers=False)
  File "/usr/lib/python2.7/logging/config.py", line 78, in fileConfig
    handlers = _install_handlers(cp, formatters)
  File "/usr/lib/python2.7/logging/config.py", line 153, in _install_handlers
    klass = _resolve(klass)
  File "/usr/lib/python2.7/logging/config.py", line 94, in _resolve
    __import__(used)
ImportError: No module named RosStreamHandler
[master] process has died [pid 1984, exit code 1, cmd rosmaster --core -p 11311 __log:=/home/asctec/.ros/log/504ce208-add8-11e1-a416-5bbefaef3a06/master.log].
log file: /home/asctec/.ros/log/504ce208-add8-11e1-a416-5bbefaef3a06/master*.log
ERROR: could not contact master [http://asctec-mastermind:11311/]
[master] killing on exit
edit retag flag offensive close merge delete

Comments

NO!

felix k gravatar imagefelix k ( 2013-04-23 23:22:01 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
0

answered 2013-04-24 07:14:21 -0600

ahendrix gravatar image

updated 2013-04-24 07:14:45 -0600

sudo apt-get update
sudo apt-get dist-upgrade
edit flag offensive delete link more

Comments

@Thomas it's not his.

felix k gravatar imagefelix k ( 2013-04-26 02:39:59 -0600 )edit

This didn't solve the problem for me, but the solution by Amishandroid did.

Pino gravatar imagePino ( 2013-09-30 09:23:38 -0600 )edit
2

answered 2013-04-23 23:53:16 -0600

Thomas gravatar image

Please do not post questions with title in capital answers. It is considered as being rude on the internet.

It seems that the Python module RosStreamHandler was not found. Did you source /opt/ros/fuerte/setups.sh before attempting to launch roscore?

Did you install ROS on Ubuntu using the precompiled binary package? Can you try to update just to be on the safe side? It seems I have a newer version of ros_comm on my machine.

edit flag offensive delete link more
1

answered 2013-06-05 10:52:34 -0600

Amishandroid gravatar image

I ran into this exact problem for everyone out there still having this problem here is how to fix it.

cd /opt/ros/fuerte/lib/python2.7/dist-packages
ls

You should see something like "ros_comm-1.8.7-py2.7.egg" and "ros_comm-1.8.16.egg-info". The problem is that it believes "ros_comm-1.8.7-py2.7.egg" is the latest version probably because it compares the two string character by character to fix this either remove the older file.

sudo rm -r ros_comm-1.8.7-py2.7.egg

or rename the file

sudo mv ros_comm-1.8.7-py2.7.egg ros_comm-1.8.7-py2.7.egg.old

Now roscore should work. No dist-upgrade or re-install required.

edit flag offensive delete link more

Comments

1

This is a really bad idea; those files are supposed to be managed by the package manager. Doing a dist-upgrade is the preferred solution.

ahendrix gravatar imageahendrix ( 2013-06-05 12:58:01 -0600 )edit

I am sorry you feel that way however for this case doing a dist-upgrade would remove all other older packages as well as update every package. Doing this in my case on the asctec mastermind this would result in more problems then it would fix.

Amishandroid gravatar imageAmishandroid ( 2013-06-05 14:42:37 -0600 )edit
0

answered 2014-06-09 14:15:39 -0600

jeff-o gravatar image

Amishandroid's fix worked for me as well, also on an Asctec Mastermind board.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-23 19:35:35 -0600

Seen: 2,080 times

Last updated: Jun 09 '14