Ask Your Question
0

viso2 couldn't find mono_odometer node

asked 2013-04-23 06:59:12 -0500

Maytheewat gravatar image

I download viso2 and build using rosmake. There was no error. However when I run it with following launch file.

<!-- example launch file for mono_odometer -->
<launch>
  <arg name="camera"/> <!-- camera must be set at launch -->
  <node name="image_proc" pkg="image_proc" type="image_proc" ns="$(arg camera)"/>
  <node name="mono_odometer" pkg="viso2_ros" type="mono_odometer" output="screen">
    <remap from="image" to="$(arg camera)/image_rect" />
    <param name="camera_height" value="0.5" /> <!-- cam is 0.5m above ground -->
    <param name="camera_pitch" value="0.0" /> <!-- cam is looking straight forward -->
  </node>
</launch>

It gave this error "ERROR: cannot launch node of type [viso2_ros/mono_odometer]: can't locate node [mono_odometer] in package [viso2_ros]"

How could I fix this problem ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-04-23 07:07:24 -0500

Stephan gravatar image

updated 2013-04-23 12:16:03 -0500

First, check if the executable is there:

rosrun viso2_ros mono_odometer

This should give no error. If the executable cannot be found it may be not compiled. If you are on a fuerte branch, use rosmake viso2_ros to compile the package. For the groovy branches, run catkin_make in your catkin workspace to compile the package.

Check if viso2_ros can be found by rospack: rospack find viso2_ros. If rospack cannot find the package, add the path to your environment variable ROS_PACKAGE_PATH or source the setup.bash of your <catkin_workspace>/devel directory.

edit flag offensive delete link more

Comments

There is no /bin/ folder after I run rosmake and viso2_ros was found by rospack find viso2_ros

Maytheewat gravatar image Maytheewat  ( 2013-04-23 07:14:51 -0500 )edit

Please post the full output of the command rosmake viso2_ros (e.g. via pastebin.com).

Stephan gravatar image Stephan  ( 2013-04-23 07:21:27 -0500 )edit

http://pastebin.com/QYS8kUp6

Maytheewat gravatar image Maytheewat  ( 2013-04-23 11:48:07 -0500 )edit

Which branch are you using? There seems to be a ROS_NOBUILD file in your viso2_ros which does not belong there. Note: if you are on the groovy or groovy-devel branch you have to use catkin instead of rospack to build the package.

Stephan gravatar image Stephan  ( 2013-04-23 12:09:47 -0500 )edit

Hmm....yes I'm on groovy, I'll try to use catkin then, Thank you very much

Maytheewat gravatar image Maytheewat  ( 2013-04-23 12:42:41 -0500 )edit

By the way, do you have any advice how to do this (use catkin to build a package) I don't have any experience doing this before

Maytheewat gravatar image Maytheewat  ( 2013-04-23 12:57:57 -0500 )edit

Please read http://www.ros.org/wiki/ROS/Tutorials/InstallingandConfiguringROSEnvironment#Create_a_ROS_Workspace You'll have to put the viso2 repository in your catkin_ws/src directory.

Stephan gravatar image Stephan  ( 2013-04-23 13:04:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-04-23 06:59:12 -0500

Seen: 901 times

Last updated: Apr 23 '13